unlim

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 31 total)
  • Author
    Posts
  • in reply to: Disk forwarding error: Failed to connect the disk D: #17416
    unlim
    Participant

    It’s too complicated.
    I believe I won’t tune this VDS anymore.

     

    Thank you!

    unlim
    Participant

    I change that line and now able to connect.

     

    Thank you!

    unlim
    Participant

    I see.
    But seems, I do that already – I disable startup script and restart whole VDS.
    What should I do more ?

    # ps -elfH
    F S UID        PID  PPID  C PRI  NI ADDR SZ WCHAN  STIME TTY          TIME CMD
    5 S root         1     0  0  80   0 –  4820 poll_s Jan06 ?        00:00:00 init
    1 S root         2     1  0  80   0 –     0 kthrea Jan06 ?        00:00:00   [kthreadd/10006]
    1 S root         3     2  0  80   0 –     0 kthrea Jan06 ?        00:00:00     [khelper]
    5 S root       459     1  0  80   0 – 44418 poll_s Jan06 ?        00:00:03   /sbin/rsyslogd -i /var/run/syslogd.pid -c 5
    5 S root       726     1  0  80   0 –  1028 n_tty_ Jan06 ?        00:00:00   /sbin/mingetty console
    5 S root       727     1  0  80   0 –  1028 n_tty_ Jan06 ?        00:00:00   /sbin/mingetty tty2
    5 S root       721     1  0  80   0 – 16577 poll_s Jan06 ?        00:00:01   /usr/sbin/sshd
    5 S root       687     1  0  80   0 –  5289 hrtime Jan06 ?        00:00:00   /usr/sbin/atd
    5 S smmsp      659     1  0  80   0 – 19579 sys_pa Jan06 ?        00:00:00   sendmail: Queue runner@01:00:00 for /var/spool/clientmqueue
    5 S root       672     1  0  80   0 –  5009 hrtime Jan06 ?        00:00:00   crond
    5 S root       628     1  0  80   0 – 16636 skb_wa Jan06 ?        00:00:00   /usr/sbin/saslauthd -m /var/run/saslauthd -a pam -n 2
    5 S root       629   628  0  80   0 – 16636 fcntl_ Jan06 ?        00:00:00     /usr/sbin/saslauthd -m /var/run/saslauthd -a pam -n 2
    5 S root       650     1  0  80   0 – 22758 poll_s Jan06 ?        00:00:02   sendmail: accepting connections
    5 S root       616     1  0  80   0 –  5441 poll_s Jan06 ?        00:00:00   xinetd -stayalive -pidfile /var/run/xinetd.pid
    5 S 68         539     1  0  80   0 –  8911 poll_s Jan06 ?        00:00:00   hald
    5 S root       540   539  0  80   0 –  5111 poll_s Jan06 ?        00:00:00     hald-runner
    5 S root       541     1  0  80   0 – 11260 poll_s Jan06 ?        00:00:00   /usr/sbin/wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -B -u -f /var/log/wpa_supplicant.log -P /var/run
    5 S root       516     1  0  80   0 – 23070 ep_pol Jan06 ?        00:00:00   cupsd -C /etc/cups/cupsd.conf
    5 S root       494     1  0  80   0 – 23142 poll_s Jan06 ?        00:00:00   NetworkManager –pid-file=/var/run/NetworkManager/NetworkManager.pid
    5 S dbus       481     1  0  80   0 –  5403 poll_s Jan06 ?        00:00:00   dbus-daemon –system
    5 S nx         218     1  0  80   0 – 149459 poll_s Jan06 ?       00:00:03   /usr/NX/bin/nxserver.bin root 1 –daemon
    5 S nx         765   218  0  80   0 – 139490 futex_ Jan06 ?       00:00:00     /usr/NX/bin/nxd
    5 S root       498     1  0  80   0 – 14521 poll_s Jan06 ?        00:00:00   /usr/sbin/modem-manager
    5 S root       144     1  0  80   0 –  2679 poll_s Jan06 ?        00:00:00   /sbin/udevd -d
    0 S root     12965     1  0  80   0 –  2873 do_wai 15:21 pts/0    00:00:00   -bash
    0 R root     12996 12965  0  80   0 –  3342 –      15:21 pts/0    00:00:00     ps -elfH

    unlim
    Participant

    I see.

    I said earlier that I already tried to run VDS w/o that script – w/o Xvfb.
    And problem not gone.
    I just tried one more time – problem still appear.

    And I do not see “Cannot detect any display running. Do you want …” in any case.
    Earlier, before this problem, I saw that message (it appears within client interface).
    But now, when I have this problem, I do not see this message (“Cannot detect…”) at all.

    in reply to: Disk forwarding error: Failed to connect the disk D: #17079
    unlim
    Participant

    Unfortunately, I can’t test other conf.
    I have win10 (local) and CentOS6 (VDS).

    Yes, I use NX client and server both 6.0.66.

    "C:/Users/username/.nx/R-"numbers"/session" log attached.

     

    Attachments:
    unlim
    Participant

    There is no /home/user/.xsession-error.

     

    How exactly can I “solution with disabled xvfb server and allow NoMachine to create the desktop” ?

    unlim
    Participant

    OK, I perform those instructions from link you suggested.

    They didn’t help.

    Pls note that this VDS was working for years. And problem start to happen for few days only (maybe from last NX update).

    Here are the output:

    # yum update -y
    Loaded plugins: fastestmirror, priorities, refresh-packagekit
    Setting up Update Process
    Determining fastest mirrors

    extras                                                                                                                                                                    | 3.4 kB     00:00
    updates                                                                                                                                                                   | 3.4 kB     00:00
    vz-base                                                                                                                                                                   |  951 B     00:00
    vz-updates                                                                                                                                                                |  951 B     00:00
    No Packages marked for Update

     

    # yum groupinstall -y “Desktop”
    Loaded plugins: fastestmirror, priorities, refresh-packagekit
    Setting up Group Process
    Loading mirror speeds from cached hostfile

    base/group_gz                                                                                                                                                             | 226 kB     00:00
    Package nautilus-2.28.4-26.el6.x86_64 already installed and latest version
    Package 1:control-center-2.28.1-41.el6.x86_64 already installed and latest version
    Package gvfs-smb-1.4.3-27.el6.x86_64 already installed and latest version
    Package xdg-user-dirs-gtk-0.8-7.el6.x86_64 already installed and latest version
    Package gnome-power-manager-2.28.3-7.el6_4.x86_64 already installed and latest version
    Package alsa-plugins-pulseaudio-1.1.0-1.el6.x86_64 already installed and latest version
    Package at-spi-1.28.1-2.el6.centos.x86_64 already installed and latest version
    Package 1:gdm-2.30.4-67.el6.x86_64 already installed and latest version
    Package notification-daemon-0.5.0-1.el6.x86_64 already installed and latest version
    Package 1:NetworkManager-0.8.1-113.el6.x86_64 already installed and latest version
    Package 1:NetworkManager-gnome-0.8.1-113.el6.x86_64 already installed and latest version
    Package polkit-gnome-0.96-4.el6.x86_64 already installed and latest version
    Package gnome-session-2.28.0-24.el6.x86_64 already installed and latest version
    Package gnome-terminal-2.31.3-11.el6_6.x86_64 already installed and latest version
    Package gnome-panel-2.30.2-16.el6.x86_64 already installed and latest version
    Package gvfs-fuse-1.4.3-27.el6.x86_64 already installed and latest version
    Package metacity-2.28.0-23.el6.x86_64 already installed and latest version
    Package gnome-screensaver-2.28.3-28.el6.x86_64 already installed and latest version
    Package yelp-2.28.1-17.el6_3.x86_64 already installed and latest version
    Package 1:dbus-1.2.24-8.el6_6.x86_64 already installed and latest version
    Package gvfs-archive-1.4.3-27.el6.x86_64 already installed and latest version
    Package 1:gdm-user-switch-applet-2.30.4-67.el6.x86_64 already installed and latest version
    Package 1:control-center-extra-2.28.1-41.el6.x86_64 already installed and latest version
    Package eog-2.28.2-4.el6.x86_64 already installed and latest version
    Package gnome-packagekit-2.28.3-10.el6.x86_64 already installed and latest version
    Package gok-2.28.1-5.el6.x86_64 already installed and latest version
    Package gnome-media-2.29.91-6.el6.x86_64 already installed and latest version
    Package gnome-vfs2-smb-2.24.2-8.el6.x86_64 already installed and latest version
    Package openssh-askpass-5.3p1-123.el6_9.x86_64 already installed and latest version
    Package pulseaudio-module-x11-0.9.21-26.el6.x86_64 already installed and latest version
    Package pulseaudio-module-gconf-0.9.21-26.el6.x86_64 already installed and latest version
    Package 1:gnome-applets-2.28.0-7.el6.centos.x86_64 already installed and latest version
    Package orca-2.28.2-1.el6.x86_64 already installed and latest version
    Package vino-2.28.1-10.el6.x86_64 already installed and latest version
    Package 1:gdm-plugin-fingerprint-2.30.4-67.el6.x86_64 already installed and latest version
    Warning: Group basic-desktop does not have any packages.
    No packages in any requested group available to install or update

    unlim
    Participant

    I perform simple VDS restart few times – and this not help.
    I have following script on server boot:
    COOKIE=ps -ef | md5sum | cut -f 1 -d " "
    AUTHFILE=$HOME/Xvfb-0.auth
    xauth -f $AUTHFILE add :0 MIT-MAGIC-COOKIE-1 $COOKIE
    xauth add :0 MIT-MAGIC-COOKIE-1 $COOKIE
    Xvfb :0 -auth $AUTHFILE -screen 0 1920x1080x24 &
    DISPLAY=:0 nohup /etc/gdm/Xsession gnome-session &

    I tried to not run that script on server boot – still no luck.

    What should I do more ?

    in reply to: Disk forwarding error: Failed to connect the disk D: #17051
    unlim
    Participant

    >> Did you check other session logs in folder /usr/NX/var/log/node/
    Yes. I look into all logs:
    tail -f  /usr/NX/var/log/node/*/session

    >> Can you paste here output of that command:
    >> $ sudo df
    Filesystem     1K-blocks      Used Available Use% Mounted on
    /dev/simfs     199229440 112007320  87222120  57% /
    none            16349940         4  16349936   1% /dev
    none            16349940      5556  16344384   1% /dev/shm

    >> Did you try to follow instructions in article about enabling disks on Centos, which we provided before?
    Yes.

    # yum install fuse dkms dkms-fuse

    Package fuse-2.8.3-5.el6.x86_64 already installed and latest version
    Package dkms-2.4.0-1.20170926git959bd74.el6.noarch already installed and latest version
    No package dkms-fuse available.
    Nothing to do

     

    >> One more thing is to switch Selinux off for testing only, you can do it with that command:
    Yes – nothing changes:
    # setenforce 0
    setenforce: SELinux is disabled
    # setenforce 1
    setenforce: SELinux is disabled

     

    Logs just sent to forum[at]nomachine[dot]com.

    in reply to: Disk forwarding error: Failed to connect the disk D: #17045
    unlim
    Participant

    That’s only I got in session log, when connects the disk:

     

    ==> /usr/NX/var/log/node/****/session <==
    Info: Forwarded new slave connection.
    Info: Closed connection to slave server.
    Info: Forwarded new slave connection.
    Info: Closed connection to slave server.
    Info: Forwarded new slave connection.
    Info: Closed connection to slave server.
    Info: Forwarded new slave connection.
    Info: Accepted new connection to filesystem server.
    Info: Closed connection to slave server.
    Info: Closed connection to slave server.
    Info: Forwarded new slave connection.
    Info: Closed connection to slave server.
    Info: Forwarded new slave connection.
    Info: Closed connection to slave server.

    unlim
    Participant

    OK, logs were sent…

    unlim
    Participant

    Thank you.
    Unfortunately, that does not change anything, problem still exists.

    # ls /usr/share/xsessions
    gnome.desktop

    # grep Exec /usr/share/xsessions/*
    Exec=gnome-session
    TryExec=gnome-session

    # grep DefaultDesktopCommand /usr/NX/etc/node.cfg
    DefaultDesktopCommand “/etc/gdm/Xsession gnome-session”

    So it does not work with that setting.
    As you suggested I have change that line to:
    DefaultDesktopCommand “gnome-session”

    and perform VDS restart.

    Result was the same, error was the same exactly.

    unlim
    Participant

    OK

    Thank you!

    unlim
    Participant

    But I already perform commands from that topic and they gave me 5.3.12 version.

    But you say “you still have an old 3.5.0 license for NX free edition in place”.
    And that’s because my update to 6x fails.

     

    How did you check that ?

    unlim
    Participant

    I perform:

    rpm -e nomachine
    rm -rf /usr/NX
    rpm -i nomachine_6.0.66_2_x86_64.rpm

     

    And now I can connect to updated VDS w/o problems – thank you!

     

    However – could you pls tell me how can I see “We see that you still have an old 3.5.0 license for NX free edition in place”?
    I need to check other servers also…

Viewing 15 posts - 1 through 15 (of 31 total)