witek

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • in reply to: Mute sound not working #29463
    Avatarwitek
    Participant

    Hi,

    Sound on the server will be not muted if NoMachine audio service does not work properly. In this case it seems that nxaudio kernel extension is not loaded. If you did not approve NoMachine kernel extensions, you can do this by following steps below:

    1. Try to load nxaudio module (the path is different than on MacOS 10.15):

    sudo kextutil -vvv /System/Library/Extensions/nxaudio.kext/

    2. Access System Preferences -> Security&Privacy -> General panel. Click on the “Allow” button (see kext_approval.png).

    3. Check if nxaudio is loaded properly:

    kextstat | grep nxau

    Output of the command above should be similar to

    265 0 0xffffff7f83cd6000 0x5000 0x5000 com.nomachine.driver.nxau (4.1.b2) 78172556-B6A4-3112-BA41-E79D18108476

    4. Restart NoMachine server using command:

    sudo /etc/NX/nxserver --restart

    If you want to transmit audio from the server to the client, Microphone permission has to be also properly set. When you connect to the iMac for the first time you should get a request that “nxnode would like to access the microphone” (see microphone_request.png). After accepting it, you should be able to see nxnode inside Microphone permission (see microphone_settings.png).

    If audio still does not work, please send us the output of kextutil command (point 1) in your reply.

    in reply to: Sound problem under MacOs Catalina #28997
    Avatarwitek
    Participant

    So I guess that the problem is still there, isn’t it?

    Yes, nxaudio kext cannot be loaded because it is rejected. Without it, audio inside NoMachine session will not work. I suspect that it is related to the article that I mentioned in my previous message (https://www.nomachine.com/AR01P00962).

    To resolve this problem, please run the command sudo kextload /Library/Extensions/nxaudio.kext on your Mac and then access System Preferences -> Security&Privacy -> General panel. Click on the “Allow” button (see attachment) and restart NoMachine server using command:

    sudo /etc/NX/nxserver --restart

    Attachments:
    in reply to: Sound problem under MacOs Catalina #28969
    Avatarwitek
    Participant

    Hi,

    It seems that nxaudio kernel extension (kext) is not loaded on MacOS Catalina. It is responsible for creating NoMachine audio adapter. You can try to load it manually by following steps below:

    1. Load nxaudio kext using command:

    sudo kextutil -vvv /Library/Extensions/nxaudio.kext

    2. Check if nxaudio is loaded properly:

    kextstat | grep nxau

    Output of the command above should be similar to

    265 0 0xffffff7f83cd6000 0x5000 0x5000 com.nomachine.driver.nxau (4.1.b2) 78172556-B6A4-3112-BA41-E79D18108476

    3. Restart NoMachine server:

    sudo /etc/NX/nxserver --restart

    4. Run NoMachine session and verify audio.

    If no output is shown in second step, we will need result of kextutil command from point 1. Did you also approved loading NoMachine kernel extensions in the Security&Privacy panel? More information you can find here:

    https://www.nomachine.com/AR01P00962

    in reply to: No Sound – Windows Server to Linux Client #28859
    Avatarwitek
    Participant

    Hi,

    When you connect to the Windows machine, NoMachine will take default output device and read audio stream from this device to transmit it to the other side. If you want to change it, you have to close the session, switch to another sound device and then connect again via NoMachine. Based on this information, can you set speakers as the default output device and then connect to the server?

    You can also check if the “exclusive mode” is not enabled for this device:

    1. Open Control Panel -> Hardware and Sound -> Sound and select the Playback tab.
    2. Select correct device from the list and click Properties.
    3. Go to Advanced tab and ensure that options in “Exclusive Mode” are disabled.

    in reply to: I hear my voice in the speakers #28747
    Avatarwitek
    Participant

    Hi,

    What is your default input and output audio device on Windows? You probably have “NoMachine Microphone Adapter” set as a default output device. In this case NoMachine records audio stream from this device and transmits it to the other side, so that is why you can hear your voice on the client side.

    If “NoMachine Microphone Adapter” is your only available option for output device you can try to add “NoMachine Audio Adapter”. Please run the following command as administrator using correct path of NoMachine executables, for example:

    "C:\Program Files (x86)\NoMachine\bin\nxservice64.exe" --deviceadd --inffile "C:\Program Files (x86)\NoMachine\bin\drivers\nxaudio\amd64\nxaudio.inf" --hardwareid *NXVAC

    After that, set “NoMachine Audio Adapter” as the default output and “NoMachine Microphone Adapter” as the default input in Windows sound settings. If you are doing it in a NoMachine session you can just use the command below to respawn nxnode process which will start audio service with new selected default device:

    taskkill /f /fi "IMAGENAME eq nxnode.bin" /fi "USERNAME eq SYSTEM"

    in reply to: No sound from remote host #28507
    Avatarwitek
    Participant

    In this case you can try to use PulseAudio loopback module which will redirect audio stream from your input device to the default output device. Please run the following command on the server and then verify audio on the client side:

    pactl load-module module-loopback source=alsa_input.usb-Burr-Brown_from_TI_USB_Audio_CODEC-00.analog-stereo

    This loaded loopback will be also visible in pavucontrol (Playback and Recording tab).

    in reply to: No sound from remote host #28453
    Avatarwitek
    Participant

    Hi,

    Do you want to transmit audio stream from the input device “PCM2901 Audio Codec Analog Stereo” to the client side (Ubuntu and MacOS)?

    NoMachine uses default sink (output device) on the server side (Linux), then reads audio stream using monitor of this sink and transmits data to the other side. You cannot change this monitor when NoMachine start to record audio. That’s why you are not able to select source other than “Monitor of PCM2901 Audio Codec Analog Stereo” in the Recording tab of pavucontrol.

    What is your default sink (output device) when the NoMachine session is running? You can check this in the pavucontrol or by using command in terminal:

    pactl info | grep Default

    in reply to: Custom sound settings #28219
    Avatarwitek
    Participant

    Hi,

    You are using Windows OS on the server machine, right?

    In this case, when you connect to the server, NoMachine will check what the default audio output device is and will transmit audio stream from this device to the other side.

    If you want to change this default device used by NoMachine, you have to do this in Windows sound settings, then close the NoMachine session and connect again.

    There is no option for now to choose it in NoMachine application when the session is running.

    Avatarwitek
    Participant

    Hi,

    We have checked your environment but we did not notice any problem like that using Ableton Live.

    NoMachine audio devices should be only used on the server side so on the client side your default audio output device should be set to headphones, speakers etc.

    On the server side NoMachine application will take default output device and read audio stream from this
    device (to transmit it to the other side). If you want to change default output device, you have to close the session
    and connect again via NoMachine.

    If you are able to hear audio from other application than NoMachine on the client
    side, I suggest to focus on the remote machine.

    1. What version of Ableton Live do you use?

    2. Does audio work always correctly when you are not running Ableton Live?

    3. What is your default sound output device? Can you please attach screenshot
    of Playback tab in Sound panel? Go to Control Panel -> Hardware and Sound -> Sound.

    4. Please check also if your default sound output device is running in the exclusive mode
    and try to disable it.

    https://answers.microsoft.com/en-us/windows/forum/all/disable-exclusion-mode-windows-audio-driver/92c92324-f189-4ae4-ba14-7c5dda7e6183

    in reply to: Missing audio activity from NoMachine client #27839
    Avatarwitek
    Participant

    Hi,

    NoMachine on the client side on the Linux system is not creating any source or sink so because of that
    you will get no result from these commands. NoMachine application should use default sound output (headphones, speakers etc.). If you are able to hear some audio from other applications I will suggest to leave it for now and focus on MacOS.

    1. Do you use NoMachine 6.10.12 on this mac 10.15?

    2. When you connect to the mac 10.15 for the first time via NoMachine
    you should get request which reports that “NoMachine” would like to
    access the microphone. Did you get it?

    3. Please can you open Settings -> Security & Privacy -> Privacy -> Microphone panel and check if
    “NoMachine” is available there (like on the attached screenshot)?

    in reply to: Opus/Audio Quality slider #27617
    Avatarwitek
    Participant

    Hi,

    The audio quality slider is related to the Opus sample rate, frame size, channels etc. All these things affect how fast the audio stream can be processed and transmitted to the other side. We are using variable bitrate encoding
    which means that bitrate can be changed depending on the audio stream to achieve more consistent quality.

    1. The lowest point (the best performance):
    Opus sample rate: 12000 Hz
    Number of channels: 1

    2. Middle position (compromise between performance and quality)
    Opus sample rate: 24000 Hz
    Number of channels: 2

    3. The highest point (the best quality)
    Opus sample rate: 48000 Hz
    Number of channels: 2

    in reply to: No sound from Ubuntu 18.04 / AWS #27297
    Avatarwitek
    Participant

    Hi,

    Are you trying to set up PulseAudio via root?

    By default PulseAudio is not intended to be run as root but you can try to use it in a system-wide mode.

    Edit the following variables in /etc/pulse/daemon.conf:

    – change daemonize = no to daemonize = yes

    – change system-instance = no to system-instance = yes

    Remember to remove ‘#’ or ‘;’ sign to uncomment line.

    After that reboot system and try to access pavucontrol.

    Please note that in some cases running PulseAudio in system-wide mode is not recommended.

    More information you can find here:

    https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/SystemWide/

    https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/WhatIsWrongWithSystemWide/

    in reply to: No audio on MacOS 10.13.6 #27111
    Avatarwitek
    Participant

    Hi,

    We will need logs to investigate the problem.

    1. Please collect NoMachine logs from this macOS 10.13. How to do this you can find here:

    https://www.nomachine.com/DT10O00163

    2. After that run the following command to gather system logs:

    cat /var/log/system.log | grep -e nxnode -e nxau >> nxsystem.log

    Please send NoMachine logs and nxsystem.log file to forum[at]nomachine[dot]com using the title of
    that forum’s thread as the mail’s subject.

    Avatarwitek
    Participant

    Hi,

    Sorry for the late response. Yes, the problem is related to the Windows system.

    when I open the sound settings in the control panel, the system shows a blue screen.

    Did you see what caused this BSOD? Could you send us mini dump file generated by the operating system? You can find it in %SystemRoot%\minidump directory (by default it should be C:\Windows\minidump). Please send it to forum[at]nomachine[dot]com using the title of that forum’s thread as the mail’s subject.

    1. As a sound output, “NoMachine microphone adapter” is selected by default. Like the sound input is the same.

    “NoMachine microphone adapter” should not be set as a default output device when you want to use microphone.

    <cite>5. First I left it as it was, then I tried to activate other sound outputs. It had no effect.</cite>

    Did you try to do this before you connect with NoMachine? If not, please set the default output device to something different than “NoMachine microphone adapter” and then connect to the server via NoMachine. Leave default input device  as it is (“NoMachine microphone adapter”).

    /witek

    in reply to: No sound on Linux #27000
    Avatarwitek
    Participant

    Sorry for the late response. We were trying to reproduce this problem but we could not.

    I need to ask more questions to investigate the problem.
    Before that, please restart the PulseAudio server on Kubuntu machine using the command bellow:

    pulseaudio -k; pulseaudio -D; sudo /etc/NX/nxserver --restart

    1. When you are connected to the host via NoMachine, what is the default sink and source on the server? You can check this with the following command:

    pactl info | grep Default

    2. From the provided list I can see that all nx sinks are created properly but “Simultaneous output to NoMachine Output” is not in the “RUNNING” state. It should be set to the default sink by the NoMachine and because of that, applications like Firefox should play on this sink. You can check if applications are using correct default sink in the “Playback” tab of pavucontrol.

    Also debug logs will be helpful in this case. How to do it you can find here:

    https://www.nomachine.com/DT10O00163#1.1

    and please send the logs archive to forum[at]nomachine[dot]com.

Viewing 15 posts - 1 through 15 (of 17 total)