zaq

Forum Replies Created

Viewing 15 posts - 16 through 30 (of 61 total)
  • Author
    Posts
  • in reply to: NoMachine can’t open #21519
    Avatarzaq
    Contributor

    Hello,

    I assume you are using Linux because you posted in the Linux forum.
    Could you tell which distro you have installed (Ubuntu, Debian, RedHat, other)?

    *.deb packages you should use for Debain, Ubuntu and similar.

    *.rpm packages are intended for: Red Hat Enterprise, SLED, SLES, Open SUSE, Mandriva, Fedora.

    *.tar.gz packages you can use for systems like Arch and others which don’t support *rpm and *deb packages.

    Is it your system headless – without graphical environment like GNOME or KDE?

    To check which package x32 or x64 you should use run this command:

    uname -a

    If in the output you got ‘x86_64’:

    Linux bee 4.4.0-124-generic #148-Ubuntu SMP Wed May 2 13:00:18 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

    please use packages x86_64 or amd64.

    If in the output you got ‘i686’:

    Linux ubuntu-1704-32bit 4.10.0-19-generic #21-Ubuntu SMP Thu Apr 6 17:03:14 UTC 2017 i686 i686 i686 GNU/Linux

    you should use i686 or i386 installation packages.

    In your situation I think that the best solution is completely reinstall:

    1) remove installation:

    for *.deb:

    sudo dpkg -P nomachine

    for *.rpm:

    sudo rpm -e nomachine

    for *.tar.gz

    sudo /usr/NX/scripts/setup/nxserver --uninstall

    2) removing all leftovers:

    sudo rm -rf /usr/NX /etc/NX /var/NX

    3) install again:

    *.deb x32:

    sudo dpkg -i nomachine_6.4.6_1_i386.deb

    *.deb x64:

    sudo dpkg -i nomachine_6.4.6_1_amd64.deb

    *.rpm x32:

    sudo rpm -i nomachine_6.4.6_1_i686.rpm

    *.rpm x64:

    sudo rpm -i nomachine_6.4.6_1_x86_64.rpm

    *.tar.gz x32:

    Click on Download and save the TAR.GZ file in the /usr directory.
    Extract the TAR.GZ archive by running from command line:

    sudo tar zxvf nomachine_6.4.6_1_i686.tar.gz

    Install NoMachine by executing:

    sudo /usr/NX/nxserver --install

    *.tar.gz x64:

    Click on Download and save the TAR.GZ file in the /usr directory.
    Extract the TAR.GZ archive by running from command line:

    sudo tar zxvf nomachine_6.4.6_1_x86_64.tar.gz

    Install NoMachine by executing:

    sudo /usr/NX/nxserver --install

    After that you should be able to see symbol of NoMachine in your
    system’s tray. In applications menu should be !M entires. Also
    NoMachine’s processes should be running:

    $ ps ax | grep nx
    7188 ? S< 0:00 /usr/NX/bin/nxexec –node –user john –priority realtime –mode 0 –pid 14
    7193 ? S<l 0:13 /usr/NX/bin/nxnode.bin
    7223 ? Sl 1:00 /usr/NX/bin/nxclient.bin –monitor –pid 2182
    20887 ? Ssl 5:50 /usr/NX/bin/nxserver.bin –daemon
    20998 ? Sl 0:00 /usr/NX/bin/nxd

    You can find more details here:

    https://www.nomachine.com/all-documents

    If you don’t see NoMachine processes you can gather logs:

    https://www.nomachine.com/DT10O00162

    and send them to forum[at]nomachine[dot]com.

    Avatarzaq
    Contributor

    Hello Richcmwang,

    Looks like the error message can be triggered by adding or changing
    any *.desktop file. It isn’t caused by error in *.desktop file. You
    can easily trigger this message by changing date:

    sudo touch /usr/share/applications/firefox.desktop

    In syslog I’ve found other type of error messsages:

    gnome-software[3456]: Failed to find one package for NoMachine-base.desktop, /usr/share/applications/NoMachine-base.desktop, [0]

    You can disable them by adding to:

    /var/lib/dpkg/info/nomachine.list

    these lines:

    /usr/share/applications/NoMachine-base.desktop
    /usr/share/applications/NoMachine-base-unity.desktop
    /usr/share/applications/NoMachine-base-xfce.desktop
    /usr/share/applications/NoMachine-nxs.desktop
    /usr/share/applications/NoMachine-nxv.desktop
    /usr/share/applications/NoMachine-status.desktop
    /usr/share/applications/NoMachine-status-unity.desktop
    /usr/share/applications/NoMachine-status-xfce.desktop

    in reply to: Enterprise Client requires admin privileges #20400
    Avatarzaq
    Contributor

    Hello,

    Please download again. There was a slight hitch with the package online
    and it’s now been fixed. Sorry for any inconvenience.

    in reply to: What is the NX User account? #19878
    Avatarzaq
    Contributor

    Looks like everything is ok. User nx is created and used by NoMachine. Also this user shouldn’t be visible in login window. Do you have other doubts?

    in reply to: What is the NX User account? #19812
    Avatarzaq
    Contributor

    Hello Fastidious,

    Nx user is needed for proper working. You can find more in:

    https://www.nomachine.com/AR01N00871

    However if you see user nx as available user in Login Window then please let us know and check using following command:

    sudo /usr/bin/defaults read /Library/Preferences/com.apple.loginwindow HiddenUsersList

    In this case helpful will be nxinstall.log, nxupdate.log from:

    /Library/Application\ Support/NoMachine/var/log/

    Log files please send to forum[at]nomachine[dot]com.

    • This reply was modified 2 years, 2 months ago by Avatarzaq.
    in reply to: Installation fails: missing ssh keyfile #19530
    Avatarzaq
    Contributor

    Hello Marty39

    Looks like you have Mint 64 bits and you installed a package for 32 bits:

    1. Download the x64 package:

    https://www.nomachine.com/download/download&id=5

    2. Uninstall current package:

    sudo dpkg -P nomachine

    3. Remove all leftovers:

    sudo rm -rf /usr/NX /etc/NX /var/NX

    4. Install new package:

    sudo dpkg -i nomachine_6.2.4_1_amd64.deb

    To check architecture of your machine you can use this command:

    uname -m

    in reply to: Centos 6 nx installation error (cannot add user: nx) #15639
    Avatarzaq
    Contributor

    Hello,

    Do you use ActiveDirectory/LDAP/domain users?

    Could you send to us output from:

    1) id nx

    2) getent passwd nx

    3) /usr/sbin/useradd -d '/var/NX/nx' -p '*' -g nx -s /bin/false -r nx

    in reply to: Doesn't work after installing new version 5.3.10_7 #15572
    Avatarzaq
    Contributor

    Hello dmanushin,

    Looks like you have 64 bits (x86_64) operating system and you installed NoMachine package
    for 32 bits (i686). I expect that you use NoMachine Free, so I use this type of installation in
    my instruction.

    Firstly please uninstall current NoMachine package:

    sudo rpm -e nomachine

    remove leftowers:

    sudo rm -rf /usr/NX /etc/NX /var/NX

    Download the right package:

    https://www.nomachine.com/download/download&id=14

    install the new package:

    sudo rpm -i nomachine_5.3.10_6_x86_64.rpm

    Now you can use NoMachine.

    in reply to: Error is 134: Protocol error (Ubuntu) #14944
    Avatarzaq
    Contributor

    Hi mikeev,

    Looks like your graphic card without a connected monitor works
    in power save mode and doesn’t draw graphics properly. This is
    the reason why you got black screen. The solution is to disable
    graphical runlevel of your headless Ubuntu 16.04. You can simple
    run:

    sudo systemctl stop gdm.service

    sudo /etc/NX/nxserver --restart

    You should got expected warning about X server.

    sudo systemctl set-default -f multi-user.target

    Now you can connect to the machine and NoMachine create graphical
    session. If you got problems with resolution you can change it in
    display settings:

    https://www.nomachine.com/changing-how-you-view-the-remote-host

    If you want to restore your previous default runlevel just execute:

    sudo systemctl set-default -f graphical.target

    and after next reboot your OS should display Gnome.

    in reply to: Error is 134: Protocol error (Ubuntu) #14844
    Avatarzaq
    Contributor

    Hello mikeev

    We couldn’t reproduce your problem in our laboratory. We need more
    information. Please follow steps below:

    1. Check if you have installed desktop environment. Please send
    the output to us.

    dpkg -l ubuntu-desktop

    ls -l /etc/X11/Xsession

    2. Check if Xorg process exists. Please send the output to us.

    ps -ef | grep -i xor | grep -v grep

    3. Gather logs:

    a) Edit the /usr/NX/etc/server.cfg file. Uncomment and set the
    following:

    SessionLogLevel 7

    b) Edit the /usr/NX/etc/node.cfg file. Uncomment and set the
    following:

    SessionLogLevel 7

    and:

    SessionLogClean 0

    c) Reboot nxserver:

    sudo /usr/NX/bin/nxserver --restart

    d) Reproduce the problem – try create connection to Ubuntu headless
    when monitor isn’t connected.

    4. Pack the whole log directory:

    tar czf log.tar.gz /usr/NX/var/log

    5. Send the log archive to forum[at]nomachine[dot]com

    Avatarzaq
    Contributor

    Hello higrys

    We couldn’t reproduce the problem in our laboratory. Could you
    reinstall NoMachine again and reproduce problem?

    1. Uninstall NoMachine:

    sudo dpkg -P nomachine

    2. Remove all directories:

    sudo rm -rf /usr/NX /etc/NX /var/NX

    3. Check architecture of your OS:

    uname -a

    If the output include: x86_64 x86_64 x86_64 GNU/Linux
    you should use x64 package:

    nomachine_5.2.21_1_amd64.deb

    if you got: i686 GNU/Linux or i386 GNU/Linux
    please use x32 package:

    nomachine_5.2.21_1_i386.deb

    4. Install NoMachine.

    x64 system:

    sudo dpkg -i nomachine_5.2.21_1_amd64.deb

    x32 system:

    sudo dpkg -i nomachine_5.2.21_1_i386.deb

    5. Gather logs and reproduce the problem like in this link:

    https://www.nomachine.com/DT07M00098#1

    and send packed logs to forum[at]nomachine[dot]com.

    Avatarzaq
    Contributor

    Hello EddieA

    Could you set in your Slackware /usr/NX/etc/node.cfg:

    DefaultDesktopCommand "/usr/bin/startSession.sh"

    Put attached script to /usr/bin/ and set this permissions:

    chown root:root /usr/bin/startSession.sh

    chmod 555 /usr/bin/startSession.sh

    and try to run NoMachine connection to your Slackware.

    • This reply was modified 3 years, 7 months ago by Avatarzaq.
    • This reply was modified 3 years, 7 months ago by Avatarzaq.
    in reply to: Cannot install NoMachine on Linux (Ubuntu Gnome) #14232
    Avatarzaq
    Contributor

    Hello,

    You can simply remove broken NoMachine installation:

    sudo dpkg -P nomachine

    sudo rm -rf /usr/NX /etc/NX /var/NX

    and install again

    • This reply was modified 3 years, 8 months ago by Avatarzaq.
    in reply to: NoMachine client missing from Applications #13930
    Avatarzaq
    Contributor

    Yes it’s a bug, it’ll be fixed in a next release.

    in reply to: NoMachine client missing from Applications #13921
    Avatarzaq
    Contributor

    Hello iainhallam

    When you installed package nomachine_5.2.11_1_x86_64.rpm you
    shouldn’t install nomachine-enterprise-client because nomachine
    ‘server’ package also includes ‘client’ part. If you need on
    your machine only NoMachine client, please just run as root:

    /usr/NX/scripts/setup/nxplayer --update

    This fixes the problem with ‘Applications’ menu entry.

    If you need installed server and client parts on your machine,
    please remove existing package:

    rpm -e nomachine-enterprise-client

    and install again:

    rpm -i nomachine_5.2.11_1_x86_64.rpm

Viewing 15 posts - 16 through 30 (of 61 total)