zaq

Forum Replies Created

Viewing 15 posts - 31 through 45 (of 69 total)
  • Author
    Posts
  • in reply to: Doesn't work after installing new version 5.3.10_7 #15572
    Avatarzaq
    Contributor

    Hello dmanushin,

    Looks like you have 64 bits (x86_64) operating system and you installed NoMachine package
    for 32 bits (i686). I expect that you use NoMachine Free, so I use this type of installation in
    my instruction.

    Firstly please uninstall current NoMachine package:

    sudo rpm -e nomachine

    remove leftowers:

    sudo rm -rf /usr/NX /etc/NX /var/NX

    Download the right package:

    https://www.nomachine.com/download/download&id=14

    install the new package:

    sudo rpm -i nomachine_5.3.10_6_x86_64.rpm

    Now you can use NoMachine.

    in reply to: Error is 134: Protocol error (Ubuntu) #14944
    Avatarzaq
    Contributor

    Hi mikeev,

    Looks like your graphic card without a connected monitor works
    in power save mode and doesn’t draw graphics properly. This is
    the reason why you got black screen. The solution is to disable
    graphical runlevel of your headless Ubuntu 16.04. You can simple
    run:

    sudo systemctl stop gdm.service

    sudo /etc/NX/nxserver --restart

    You should got expected warning about X server.

    sudo systemctl set-default -f multi-user.target

    Now you can connect to the machine and NoMachine create graphical
    session. If you got problems with resolution you can change it in
    display settings:

    https://www.nomachine.com/changing-how-you-view-the-remote-host

    If you want to restore your previous default runlevel just execute:

    sudo systemctl set-default -f graphical.target

    and after next reboot your OS should display Gnome.

    in reply to: Error is 134: Protocol error (Ubuntu) #14844
    Avatarzaq
    Contributor

    Hello mikeev

    We couldn’t reproduce your problem in our laboratory. We need more
    information. Please follow steps below:

    1. Check if you have installed desktop environment. Please send
    the output to us.

    dpkg -l ubuntu-desktop

    ls -l /etc/X11/Xsession

    2. Check if Xorg process exists. Please send the output to us.

    ps -ef | grep -i xor | grep -v grep

    3. Gather logs:

    a) Edit the /usr/NX/etc/server.cfg file. Uncomment and set the
    following:

    SessionLogLevel 7

    b) Edit the /usr/NX/etc/node.cfg file. Uncomment and set the
    following:

    SessionLogLevel 7

    and:

    SessionLogClean 0

    c) Reboot nxserver:

    sudo /usr/NX/bin/nxserver --restart

    d) Reproduce the problem – try create connection to Ubuntu headless
    when monitor isn’t connected.

    4. Pack the whole log directory:

    tar czf log.tar.gz /usr/NX/var/log

    5. Send the log archive to forum[at]nomachine[dot]com

    Avatarzaq
    Contributor

    Hello higrys

    We couldn’t reproduce the problem in our laboratory. Could you
    reinstall NoMachine again and reproduce problem?

    1. Uninstall NoMachine:

    sudo dpkg -P nomachine

    2. Remove all directories:

    sudo rm -rf /usr/NX /etc/NX /var/NX

    3. Check architecture of your OS:

    uname -a

    If the output include: x86_64 x86_64 x86_64 GNU/Linux
    you should use x64 package:

    nomachine_5.2.21_1_amd64.deb

    if you got: i686 GNU/Linux or i386 GNU/Linux
    please use x32 package:

    nomachine_5.2.21_1_i386.deb

    4. Install NoMachine.

    x64 system:

    sudo dpkg -i nomachine_5.2.21_1_amd64.deb

    x32 system:

    sudo dpkg -i nomachine_5.2.21_1_i386.deb

    5. Gather logs and reproduce the problem like in this link:

    https://www.nomachine.com/DT07M00098#1

    and send packed logs to forum[at]nomachine[dot]com.

    Avatarzaq
    Contributor

    Hello EddieA

    Could you set in your Slackware /usr/NX/etc/node.cfg:

    DefaultDesktopCommand "/usr/bin/startSession.sh"

    Put attached script to /usr/bin/ and set this permissions:

    chown root:root /usr/bin/startSession.sh

    chmod 555 /usr/bin/startSession.sh

    and try to run NoMachine connection to your Slackware.

    • This reply was modified 4 years, 3 months ago by Avatarzaq.
    • This reply was modified 4 years, 3 months ago by Avatarzaq.
    in reply to: Cannot install NoMachine on Linux (Ubuntu Gnome) #14232
    Avatarzaq
    Contributor

    Hello,

    You can simply remove broken NoMachine installation:

    sudo dpkg -P nomachine

    sudo rm -rf /usr/NX /etc/NX /var/NX

    and install again

    • This reply was modified 4 years, 3 months ago by Avatarzaq.
    in reply to: NoMachine client missing from Applications #13930
    Avatarzaq
    Contributor

    Yes it’s a bug, it’ll be fixed in a next release.

    in reply to: NoMachine client missing from Applications #13921
    Avatarzaq
    Contributor

    Hello iainhallam

    When you installed package nomachine_5.2.11_1_x86_64.rpm you
    shouldn’t install nomachine-enterprise-client because nomachine
    ‘server’ package also includes ‘client’ part. If you need on
    your machine only NoMachine client, please just run as root:

    /usr/NX/scripts/setup/nxplayer --update

    This fixes the problem with ‘Applications’ menu entry.

    If you need installed server and client parts on your machine,
    please remove existing package:

    rpm -e nomachine-enterprise-client

    and install again:

    rpm -i nomachine_5.2.11_1_x86_64.rpm

    in reply to: Server not fully starting, can’t connect #13761
    Avatarzaq
    Contributor

    Looks like you are trying to connect by SSH protocol to the port 4000.
    To fix this you can create a new connection in nxplayer and use
    default settings or you can change your current connection:

    1. Open nxplayer and find icon of your current connection.

    2. Click right mouse button on the connection.

    3. From a context menu choose ‘Edit connection’.

    4. In ‘Protocol’ field choose NX.

    5. In ‘Port’ field set 4000.

    6. Accept your changes by clicking ‘OK’ button.

    After the fix if you still have problem, please try connect again.
    Wait until error shows up in nxplayer and then click ‘Save logs’
    button. Please save and send the log file to us.

    in reply to: Not able to Launch application #12268
    Avatarzaq
    Contributor

    Hello,

    I can see that you use package for 32 bit OS. Could you confirm that you have x32 Ubuntu?
    Please run in terminal:

    uname -a

    uname -p

    or in Unity Search:

    System Settings -> Details -> Overview -> OS type

    if in output you find i686 or 32-bit, please send to forum[at]nomachine[dot]com
    output from installation and a packed log directory:

    /usr/NX/var/log

    If you have 64 bit OS, please try:

    https://www.nomachine.com/download/download&id=1

    sudo dpkg -i nomachine_5.1.44_1_amd64.deb

    • This reply was modified 4 years, 11 months ago by Avatarzaq.
    in reply to: Cannot create the home directory for the nx user #11614
    Avatarzaq
    Contributor

    Hello Hugga,

    Do you use on your PCs Active Directory or similar technology?
    Is ‘nx’ a domain user?

    Could you zip whole log dir on both machines (PC1,PC2):

    C:\ProgramData\NoMachine\var\log

    and sent to forum[at]nomachine[dot]com, please.

    in reply to: Unable to install NoMachine on Windows 7 #11261
    Avatarzaq
    Contributor

    Hello Greenrose,

    Could you zip whole log dir:

    C:\ProgramData\NoMachine\var\log

    and sent to forum[at]nomachine[dot]com, please.

    Is it something unusual in settings of your PC?
    Is the OS installed on a USB drive? Is it a virtual machine?

    Avatarzaq
    Contributor

    Hello Canufrank

    Looks like your computer processor is 32-bit. NoMachine needs 64-bit CPU.

    You can check this by run in terminal:

    1. CPU name:

    sysctl -n machdep.cpu.brand_string

    “Core Solo” or “Core Duo” CPU it’s 32-bit only

    2. Check if your CPU supports 64-bit:

    sysctl hw.cpu64bit_capable

    Avatarzaq
    Contributor

    Hi,

    open a terminal and tell me the output of this command:

    sw_vers

    uname -a

    If the output of ‘uname’ includes i386 or x86please send also this packed dir:

    tar czf log.tar.gz /Library/Application\ Support/NoMachine/var/log/

    Please use this e-mail:

    forum[at]nomachine[dot]com

    if they are too large to attach in the forums.

    in reply to: Runtime error during installation Windows 10 #10548
    Avatarzaq
    Contributor

    Hello,

    We have prepared a debug package and can send you the link.

    Please send logs from the installation, even when everything will be ok:

    forum[at]nomachine[dot]com

Viewing 15 posts - 31 through 45 (of 69 total)