Forum Replies Created

Viewing 5 posts - 31 through 35 (of 35 total)
  • Author
  • Zenith


    Sorry for the late response.

    I tried to do what you said. In var/log there is no auth.log file…

    I can’t find ‘connection details/advanced’ in the player (that is the Windows client right?)

    I used the following command as mentioned in the ‘How to gather debug logs for support requests’ from the Knowledge Base.:

    oem@Zenith:~$ sudo tar cvfz NoMachine-log.tar.gz /usr/NX/var/log
    [sudo] password for oem:
    tar: Removing leading `/’ from member names

    This produced the following files and folders (if not already present before I executed the command):

    folders: archives, logrotate, node
    files: nxd, nxerror, nxinstall, nxserver (all .log)

    I can’t copy/paste nxerror.log and nxserver.log to my NAS or Windows machine. I get the following error:
    Error opening file /usr/NX/var/log/nxerror.log: Permission Denied. Despite elevated privileges in the log folder.

    I also can’t find the /usr/NX/etc/pam.d/su module configuration. There is nothing located with the name ‘pam.d’ in the etc folder.

    Where do I go from here?

    Thanks in advance


    I’m sorry I have not noticed before

    No problem of course!

    This is not an connection attempt to the remote machine. This is an attempt to change settings on the server for the local machine.

    That is correct, but since I noticed that “Changes disabled” lock icon there. Which I never seen before, I thought I made a screenshot of that.

    A screenshot of the Windows Client saying “Authentication failed, please try again.” didn’t seem necessary to post here.

    I’m not quite sure what you mean with “use New connection” or the “nxplayer” application. Here are two screenshots of what I’m seeing in the Windows client:

    So nothing strange there, except the error of course. I emailed the log like you said. Have you any idea what kind of ETA I can expect on an answer?

    Thanks again for the reply!


    I just now see that I get an error for this command:
    sudo /usr/NX/bin/nxserver –useradd <username>

    After I try to set the password I get the following error:
    NX> 500 ERROR: Invalid command: ‘-useradd’

    And then followed by a lot info about the various commands and options. So in hindsight, something has gone wrong at this step it seems…



    Thanks for the reply! I’m aware of the differences between STUN and Server, I just copied the wrong part. But since every post has to await moderation I couldn’t edit it anymore.

    Logging in with system credentials simply doesn’t work (with EnableUserDB and EnablePasswordDB set to: 0). I want to control my Linux machine remotely, so I checked my username with the command: whoami (= oem (no clue why, haven’t chosen this myself)

    I have to use my password often in Linux for certain proceedings, so there can’t really go much wrong there I feel (nothing?).

    2. Run ‘sudo /usr/NX/bin/nxserver –useradd <username>’ again and see if you have password prompt, if yes, please
    provide it and use that password to login. Be sure you are using NX protocol.

    After that I get:
    [sudo] password for oem:

    Once I set that it seems to be good. I get a lot of info, but no errors or such it seems. At the bottom it says: Run a new nxserver shell.
    When I run NoMachine server on the Linux machine it looks like this:

    So it does mention ‘Changes disabled’ at the left bottom. I don’t feel that always has been there.

    When I try to login on the Windows client now I get the same error. Just to be clear… I edited the server.cfg fiel on both machines the same way! I assume that this is correct?!

    4. If it still does not work, please set in server.cfg

    When changing EnableUserDB and EnablePasswordDB back to 0 (zero) and try to login using the system credentials (so user: oem + password) I also still get the same error.
    Again to be sure, I changed both server.cfg files. The one on the Linux machine (server) and the Windows machine (client). And only before EnableUserDB, EnablePasswordDB and the server details I removed the # symbol. All the other text still has the # symbol in front of each line.

    I made a compressed archive of the .nx directory and I will e-mail this. There is no nxtrace.log present/generated.


    So someone on Reddit told that I should remove the brackets, so I did and now it looks like this:

    # When WebRTC is enabled, set parameters for STUN/TURN utilities to
    # permit NAT traversal for peer to peer direct video, audio and data
    # streaming. Replace ‘hostname’ and ‘portnumber’ with the ip or host
    # name of the network server; replace ‘username’ and ‘password’ with
    # username and password to be used for authenticating to such server.
    # If a TURN server has to be contacted, duplicate section below, set
    # it to Section “TURN” and provide the appropriate values for Host,
    # Port, User and Password parameters. Define multiple sections for
    # different STUN or TURN servers to provide an alternative server
    # in case the first of the list is not reachable.
    # Section “STUN”
    Port           4000
    User          username
    Password  password
    # EndSection

    But it still doesn’t work. So I must still be doing something wrong. Even the server on my Linux Machine gives the authentication error now:

    Hope somebody can help me out…

Viewing 5 posts - 31 through 35 (of 35 total)