Black screen with mouse showing upon login

Forums / NoMachine for Linux / Black screen with mouse showing upon login

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #39517
    Liftaren
    Participant

    Hi,

    Since installing Fedora 36 I have had problems with NoMachine. Started with 7.9.x and now with 7.10.1.

    Problem: black screen with mouse showing upon login.

    Tested with the same problem on the following distros: Fedora 36, Ubuntu 22.04, OpenSUSE Tumbleweed (also on Gnome 42). I have tested the client in both Xorg and Wayland sessions.

    Working without problems on the following distros: Linux Mint 20.3, MX Linux 21.1

    (also working from other computers with Windows and iOS, so the server side seems completely fine)

    Client side has an AMD 6800 XT, using mesa drivers. Have tested two different computers as servers with the same behavior.

    The solution for Fedora 36 client (not sure if it is Gnome or perhaps mesa?, or something else) was to setup the server with specified hardware acceleration and not use H264 (both VP8 and MJPEG works).

    NoMachine Free version, server(s) has physical display and Alma Linux 8.x (CentOS 8 Stream).

    #39525
    Britgirl
    Keymaster

    It could be related to the drivers on the client-side Linux machine you mention. You said you’ve tried connecting from Fedora 36, Ubuntu 22.04 and OpenSuse Tumbleweed. Are these distros tested from the same machine, so you are just changing the Linux distro, or are you connecting from different Linux machines?

    Logs would be useful from both sides of a problematic session, so we can eliminate possible causes.

    https://kb.nomachine.com/DT11R00182
    https://kb.nomachine.com/DT11R00181

    Send them directly to forum[at]nomachine[dot]com or attach here.

    #39651
    Liftaren
    Participant

    Hi,

    I did not manage to produce any logs. However, what I did manage was to upgrade Mesa on Ubuntu 20.04 from the 21.x branch to the 22.x that both Fedora 36 and Ubuntu 22.04 are on.

    Ubuntu 20.04 with Mesa 21.x –> works fine without any problems

    Ubuntu 20.04 with Mesa 22.x –> same type of graphical issues as with Fedora 36, Tumbleweed and Ubuntu 22.04.

    (I also tested Linux Mint 21 XFCE which had the same problem so this is not related to GNOME).

    It seems very likely that the issue with NoMachine is related to the Mesa drivers.

    #39674
    MegaSlonic
    Participant

    Hello! I have a similar problem – a black screen and a mouse cursor. I think GDM3 does not start. The problem was noticed around Jul 30. The client and the Server are both on Ubuntu 22.04. Client on the Mesa Radeon by Ubuntu community driver, and server on proprietary Nvidia v.470 driver. NoMachine v.7.10.1  deb64

    Until Jul 30, the problem was not observed. It worked all before. NoMachine settings have not changed. Only updated core and video drivers.

    #39692
    fra81
    Moderator

    @MegaSlonic

    Disabling H.264 solved the issue for Liftaren. Is it the same for you?

     

    And can you both try to check ‘Disable client side hardware decoding’ in the Display settings tab of the menu panel (Modify button)? Is this enough to solve the problem even when using H.264?

    And as Britgirl mentioned, logs would be useful, especially client side logs:

    https://kb.nomachine.com/DT11R00181#2.1

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.