Blank screen connecting to CentOS

Forums / NoMachine for Linux / Blank screen connecting to CentOS

  • This topic has 1 reply, 2 voices, and was last updated 7 months ago by Mth.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #35771
    hqmb
    Participant

    Local client: Windows 10
    Remote server:
    Distributor ID: CentOS
    Description:    CentOS Linux release 7.9.2009 (Core)
    Release:        7.9.2009
    NoMachine version: 7.6.2

    The problem arises connecting to a virtual display.
    I have two servers running the same release of CentOS, followed the steps of this link https://forums.nomachine.com/topic/black-screen-connecting-to-physical-display and it fixed the problem one of the servers. Attached are the logs I captured from the failing server, appreciate if you could help me.

    #35818
    Mth
    Contributor

    Hello

    Thank you for reporting this issue. Unfortunately the logs you provided are not conclusive.
    To investigate it further we would require the content of .nx directory from home
    directory of the user you are logging in with NoMachine player.

    Please use to collect logs:
    https://knowledgebase.nomachine.com/DT11R00182

    Please use the part 1: Short Instructions, but after enabling logs (point 1), please run:

    /etc/NX/nxserver --restart

    And following this should automatically generate the archive with everything we need.

    Additionally please check the /usr/NX/etc/node.cfg file on the server machine
    and provide us with the value of DefaultDesktopCommand key.

    /Mth

Viewing 2 posts - 1 through 2 (of 2 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.