Cannot detect any display running. Do you want NoMachine to create a new display

Forums / NoMachine for Linux / Cannot detect any display running. Do you want NoMachine to create a new display

Tagged: , ,

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #30172
    Avatarceusebio
    Participant

    Hi,

    i looked for this error on your forum and i find already some posts pointing to the same issue.
    https://forums.nomachine.com/topic/cannot-detect-any-display-running-4

    I decided to send you the log files i gathered, directly because the procedures listed in that post are not working for me, i’d need some help to fix the problem.

    I need to connect from a windows 10 pc to a Centos 7.7 workstation at work, which uses 3D accelerated softwares (Maya, Houdini etc.)

    I was using NoMachine successfully for moths (even if it was very slow) and one day it just stopped working, i had very blurry GUI and ghost images of the windows duplicating on the screen so that it was impossible to even click on something or see the contents. I restarted the machine and then i had the error

    Cannot detect any display running. Do you want NoMachine to create a new display and proceed to connect to the desktop?

    if i click YES i’m able to connect but:
    – the usual linux GUI (i’m using centos 7.7) displays like centos 8
    – my desktop misses all the files i had
    – the connection is super slow (like 2 seconds just to right-click)

    it’s like i’m logging in with a different user and that user gets the centos 8 default settings.

    I reinstalled NoMachine with yum, and updated to version 6.11.2 (both windows and linux).

    I followed the procedure to collect the logs and i’m sending them to you hoping you could help me with that. If there’s something more i could do to provide more details about my systems please let me know.

    Thanks for letting me know.

    Attachments:
    #30288
    AvatarMth
    Contributor

    Hello

    The message:

    Cannot detect any display running. Do you want NoMachine to create a new display and proceed to connect to the desktop?

    Means that you do not connect to the physical session, but rather to the virtual session created by the NoMachine. It will most likely have default settings, so that is not a problem. The problem is that the NoMachine could not detect the running desktop session.

    Unfortunately the logs You provided are not enough to see what is happening.

    Currently there is an issue with new Wayland update where change to Xsockets prevent NoMachine from accessing it, so please check if that is the case and perhaps consider disabling it until the patched NoMachine version is released. If it is not Wayland issue please help us debug it by providing more detailed logs from the server machine.

    Please follow the article on how to enable debug:

    https://www.nomachine.com/DT10O00163 (“How to gather debug logs for support requests”)

    Then please do:

    sudo /etc/NX/nxserver --restart

    Gather the logs either manually or by executing:

    sudo /etc/NX/nxserver --debug --collect

    Please note this has to be done on the machine you are trying to connect to and send the logs to forum[at]nomachine[dot]com using the title of this forum’s thread
    as the mail’s subject.

    /Mth

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.