Can’t connect to Linux PC from Mac over internet

Forums / NoMachine for Mac / Can’t connect to Linux PC from Mac over internet

This topic contains 4 replies, has 2 voices, and was last updated by Avatar Britgirl 2 months, 1 week ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #22625
    Avatar
    artygirl24
    Participant

    Hello,

    I have set up a connection to my Linux PC on my MacBook through the NoMachine wizard. I have stuck to the defaults when setting it up and just entered the IP address shown on the Linux pc, as it did not come with a port number. I can connect when I’m on the LAN but when I am at home I cannot connect through the internet.  An error appears saying:

    A connection timeout has occurred while trying to connect to 'IP ADDRESS HERE' on port '4000'. The issue could either be caused by a networking problem, by a firewall or NAT blocking incoming traffic or by a wrong server address. Please verify your configuration and try again.

    I can’t seem to find anything online, so I was wondering if someone could help me. I’m a biology PhD student so technical computer stuff isn’t my forte, unfortunately, so anything I have found online so far hasn’t really helped. My internet is working perfectly fine though and I can connect using TeamViewer. I would stick with TeamViewer but it’s only free for personal use, and it classes PhD research as commercialisation. Any help with this matter would be greatly appreciated.

    Thanks!

    #22630
    Avatar
    Britgirl
    Keymaster

    Hi, sorry to hear you’re having problems.

    Are you able to connect from the Linux machine to your Mac? Is the Linux server behind an office or uni router? Please consult this article for trouble-shooting you should read this article here: https://www.nomachine.com/AR11L00827 and let us know.

     

    #22631
    Avatar
    artygirl24
    Participant

    Hello,

    The linux server is behind a uni router yes. I have not tried connecting to my mac from the linux pc through the internet (only on LAN when testing it out initially). It does work though when connected on the LAN. I’ll have a look at the article you sent and I’ll try and figure it out; if I get stuck I’ll let you know. Thanks for your help!

    Katie

    #22632
    Avatar
    artygirl24
    Participant

    Hi,

    I went through the article and checked the server.cfg files and the UPnP is enabled. I’ve attached the files so you can have a look through and see if there are any errors/things that need changing. I’m not sure how to check whether UPnP is enabled on the router though.
    Another thing I noticed when using NoMachine is that the gateway port on my mac works, but when I tick it and restart the server on the linux pc it comes up with the error: ‘Failed to map port to the gateway’.

    #22635
    Avatar
    Britgirl
    Keymaster

    Let’s check some other details first (you may have already checked this, I’m not sure):

    1) https://www.nomachine.com/getting-started-with-nomachine#internet
    Figs 9 and 10 can show you which IP you should be using to connect from the external network.
    Quoting from the guide: “NoMachine will display it like this: nx://151.1.192.128:29382. Write this information down. If a port number is not displayed next to the external IP, NoMachine has detected that you don’t need it in the next phase.”

    There is the possibility that you have a double NAT in place, but this would mean intervening on both routers. There is a similar topic here: https://forums.nomachine.com/topic/error-138-cant-connect-to-office-computer-from-home

    NoMachine Network, the upcoming feature, would resolve this problem. It would avoid having to know your computer’s public-facing IP address and eliminate the need to configure port-forwarding on the router.

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.