Incorrect mapping of `~ key on macOS (after upgrade from 7.7.2 to 7.7.4)

Forums / NoMachine for Mac / Incorrect mapping of `~ key on macOS (after upgrade from 7.7.2 to 7.7.4)

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #35973
    mato
    Participant

    I ran NoMachine 7.7.2 on two Macs (running 10.15.7 and 10.14.6) without issues. Yesterday I updated one of them (server) to the latest version 7.7.4 and probably because of that I now have an issue with the `~ key (the one just below Escape key on US keyboard). The key works fine when sitting directly at either of the computers. But when I connect via NoMachine that specific key produces § and ± instead. I had British keyboard selected in macOS preferences on the client and that worked fine but I changed it to the US since but that not helped. I’m not sure what to do but being unable to use the key is a major problem (I cannot switch windows within a same application, I cannot type those symbols easily and they are vital in programming, etc).

    How can this be resolved please ? … Thanks!

    #36010
    Carin
    Participant

    Hi mato,

    Can you let us know the following:
    – what is the Mac version on the server-side?
    – does sending keyboard events with on-screen keyboard makes any difference (clicking mouse on that keyboard to produce~)?
    – is the same keyboard layout used on client and server, US/US or UK/UK?
    Thanks!

    #36060
    mato
    Participant

    Hi Carin,

    – the server is running macOS 10.14.6 and the client is running macOS 10.15.7
    – none of them were updated around the time my problem appeared but NoMachine was updated on the server (and later on the client too as I tried to resolve the issue)
    – what on-screen keyboard do you have in mind and how to activate it, please?
    – yes, I tried and I use the same keyboard layouts on both sides. and I have Apple’s Magic Keyboard with Numeric Keypad on the client side (US version).

    Thanks and regards!

    #36093
    Carin
    Participant

    Can you enable it on both sides and let us know what is highlighted when you press the problematic key?
    You can take a look at this article: https://support.apple.com/guide/mac-help/use-the-accessibility-keyboard-mchlc74c1c9f/mac

    #37003
    mato
    Participant

    This is in reply to https://forums.nomachine.com/topic/incorrect-mapping-of-key-on-macos-after-upgrade-from-7-7-2-to-7-7-4 which was closed likely because I haven’t replied there in time. I’m sorry. So here’s my reply:

    Hi Carin. It appears that while U.S. keyboard is selected on both sides, the on-screen keyboard on the client side matches my keyboard layout (‘~ under esc and next to 1, \| above return key (which is horizontal)) and produces desired characters on the client side. The on-screen keyboard on the server side, though, shows a different layout (§± under esc and next to 1, \| to the left of return key (which is vertical), ‘~ next to the left shift). If I change to British – PC on the server, some keys change but the physical layout stays the same and does not match the one on the client.

    #37159
    fra81
    Moderator

    Hi mato,

    this behaviour can’t be fixed on NoMachine’s side. NoMachine simulates the press of physical keys by sending the physical key codes. How they are translated to specific symbols depends on the remote system. In short, if you have the §± symbols in the on-screen keyboard (whose layout only depends on the remote system) for that specific key, these are the symbols that it will be possible to input with NoMachine. The fact you can have one layout or the other for that key depends, I think, also on the keyboard hardware you have attached to the Mac, that you actually use for typing on the server, and not just on the input source settings.

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as closed, you can't post.