Is the new sound system on Fedora 34 compatible with NoMachine?

Forums / NoMachine for Linux / Is the new sound system on Fedora 34 compatible with NoMachine?

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #33200
    AvatarValorCat
    Participant

    I upgraded all my studio machines to Fedora 34.
    I am now unable to edit video or animate to audio with my client devices.

    My theory is the new pipewire audio is incompatible? (Coming from the old PulseAudio)

    I don’t entirely know, but I’ve futsed with all the audio settings and I just can’t seem to get any audio to play….

    Once this is ironed out NoMachine will still be my favorite Linux remote desktop!

    Cheers!
    Ben

    #33236
    Avatarwaicool20
    Participant

    I have the same issue, I opened an issue on the Pipewire repo but having no luck at the moment, if you can drop some logs and comments there it might help expedite the fix.

    https://gitlab.freedesktop.org/pipewire/pipewire/-/issues/1106

    #33245
    Avatarfisherman
    Moderator

    NoMachine is currently not supporting pipewire, we have opened new Feature Request FR05S04169 – Adding support to PipeWire Sound Server. You can subscribe to the mailing list to be notifed when this FR is implemented by selecting “Notify me when the FR is implemented” and adding your email address.

    To be able to use audio in the session we can advice to use workaround mentioned in the Feature Request.

    #33319
    AvatarValorCat
    Participant

    I did what you suggested: installed PulseAudio to both host and client.

    Nada…. even after futzing with audio settings on both sides audio simply won’t work on the client.

    I love NoMachine… but she no longer loves me back 💔

    #33369
    Avatarfisherman
    Moderator

    Can you execute after installing pulseaudio following command:
    /usr/NX/scripts/setup/nxnode --audiosetup

    or check this forum post no-audio-and-microphone-with-pulseaudio

    #33373
    AvatarValorCat
    Participant

    That worked!! Thank you!
    But unfortunately, DaVinci Resolve 17 no longer outputs audio… on NoMachine or my computer..

    #33386
    Avatarfisherman
    Moderator

    Possibly DaVinci Resolve is now configured to use PipeWire and you need to select PulseAudio. Can you check possibly if you can select PulseAudio in DaVinci Resolve Preferences > Video and Audio I/O.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.