KDE/Plasma 5.17 session doesn’t start

Forums / NoMachine for Linux / KDE/Plasma 5.17 session doesn’t start

This topic contains 8 replies, has 3 voices, and was last updated by Avatar eugenez 3 weeks, 6 days ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #24061
    Avatar
    eugenez
    Participant

    Hello.

    Archlinux with KDE and last Plasma 5.17, NoMachine 6.8.1-1

    In this Plasma release /usr/bin/startkde script was discontinued, and for start KDE session need to use /usr/bin/startplasma-x11 binary.

    When connecting to a remote machine, a “Oops! Cannot run startkde. Please ensure thet the requested application is in the system PATH and that you have appropriate credentials to execute it” message appears.

    in /usr/NX/node.cfg replace

    DefaultDesktopCommand “/usr/bin/dbus-launch –exit-with-session startkde”

    to

    DefaultDesktopCommand “/usr/bin/dbus-launch –exit-with-session startplasma-x11”

    or

    DefaultDesktopCommand “/usr/bin/startplasma-x11”

    then restart nxserver and trying to connect again – error message “Session negotiation failure” appears

    in journalctl:

    [code]

    окт 17 20:26:18 lab-urm2 startplasma-x11[18753]: “dbus-update-activation-environment” (“–systemd”, “–all”) exited with code 71

    окт 17 20:26:19 lab-urm2 startplasma-x11[18753]: “xmessage” (“-geometry”, “500×100”, “Could not sync environment to dbus.\n”) exited with code 11

    окт 17 20:26:27 lab-urm2 startplasma-x11[19023]: “dbus-update-activation-environment” (“–systemd”, “–all”) exited with code 71

    окт 17 20:26:28 lab-urm2 startplasma-x11[19023]: “xmessage” (“-geometry”, “500×100”, “Could not sync environment to dbus.\n”) exited with code 11

    окт 17 20:26:38 lab-urm2 startplasma-x11[19294]: “dbus-update-activation-environment” (“–systemd”, “–all”) exited with code 71

    окт 17 20:26:39 lab-urm2 startplasma-x11[19294]: “xmessage” (“-geometry”, “500×100”, “Could not sync environment to dbus.\n”) exited with code 11

    окт 17 20:26:45 lab-urm2 kdeinit5[17158]: kdeinit5: Fatal IO error: client killed

    окт 17 20:26:45 lab-urm2 kdeinit5[17158]: kdeinit5: sending SIGHUP to children.

    окт 17 20:26:45 lab-urm2 kdeinit5[17165]: The X11 connection broke (error 1). Did the X11 server die?

    окт 17 20:26:45 lab-urm2 gmenudbusmenuproxy[17222]: The X11 connection broke (error 1). Did the X11 server die?

    окт 17 20:26:45 lab-urm2 kdeconnectd[17224]: The X11 connection broke (error 1). Did the X11 server die?

    окт 17 20:26:45 lab-urm2 polkit-kde-authentication-agent-1[17219]: The X11 connection broke (error 1). Did the X11 server die?

    окт 17 20:26:45 lab-urm2 org_kde_powerdevil[17264]: The X11 connection broke (error 1). Did the X11 server die?

    окт 17 20:26:45 lab-urm2 kdeinit5[17158]: kdeinit5: sending SIGTERM to children.

    окт 17 20:26:45 lab-urm2 kdeinit5[17158]: kdeinit5: Exit.

    [/code]

    If replace startplasma-x11 to, e.g., startlxde – works fine.

    Is there a way to run KDE with Plasma 5.17 remotely?

    Thank you.

    (sorry for my bad English 🙁 )

    #24080
    Avatar
    Britgirl
    Keymaster

    Hi, thanks for reporting, we’ve opened a Trouble Report and provided the correct workaround. To avoid further confusion and splitting of topics, please refer to https://forums.nomachine.com/topic/nx-wont-work-with-recent-kde-5-17. Thanks!

    #24083
    Avatar
    eugenez
    Participant

    Session has loaded, but window decorations are not rendered.

    And I couldn’t get into the session opened on the desktop remotely.

     

    Attachments:
    #24089
    Avatar
    og00r
    Contributor

    Could you try:
    add “env -u WAYLAND_DISPLAY” to DefaultDesktopCommand

    DefaultDesktopCommand “env -u WAYLAND_DISPLAY /usr/bin/dbus-launch –sh-syntax –exit-with-session /usr/bin/startplasma-x11” ?

     

    This should work for any installations running NoMachine virtual desktop sessions (e.g you have Workstation installed) and also the free version when NoMachine uses its own embedded X server. To be able to run a physical desktop session, a patch from us is required. We are preparing a package that will fix the issues reported here and will let you know when it’s ready.

    #24098
    Avatar
    eugenez
    Participant

    1. With workaround DefaultDesktopCommand “env -u WAYLAND_DISPLAY /usr/bin/dbus-launch /usr/bin/startplasma-x11”

    #/etc/NX/nxserver –restart

    awk: cmd. line:1: warning: regexp escape sequence `\”‘ is not a known regexp operator

    NX> 162 Disabled service: nxserver.

    NX> 162 Service: nxnode already disabled.

    NX> 162 Disabled service: nxd.

    NX> 162 Disabled service: nxserver.

    NX> 162 Disabled service: nxnode.

    NX> 162 Disabled service: nxd.

    Windows decorations are OK, but not in new, not worked, session

    2. With DefaultDesktopCommand “env -u WAYLAND_DISPLAY /usr/bin/dbus-launch –sh-syntax –exit-with-session /usr/bin/startplasma-x11” – error “Session negotiation failure”

    # /etc/NX/nxserver –restart

    awk: cmd. line:1: warning: regexp escape sequence `\”‘ is not a known regexp operator

    NX> 162 Disabled service: nxserver.

    NX> 162 Service: nxnode already disabled.

    NX> 162 Disabled service: nxd.

    NX> 111 New connections to NoMachine server are enabled.

    NX> 161 Enabled service: nxserver.

    NX> 162 WARNING: Cannot find X servers running on this machine.

    NX> 162 WARNING: A new virtual display will be created on demand.

    NX> 161 Enabled service: nxd.

    #24096
    Avatar
    eugenez
    Participant

    Windows decorations are ok, thanks.

    #24107
    Avatar
    og00r
    Contributor

    So I assume virtual sessions are working correctly right now?

    About warning during restart and physical session.

    ‘NX> 162 WARNING: Cannot find X servers running on this machine.

    NX> 162 WARNING: A new virtual display will be created on demand.’

    It happens, because NoMachine can not find correct session with new plasma in version 5.17.
    There is a Trouble Report for it:

    https://www.nomachine.com/TR10Q09441

    As there is not workaround at this moment we could prepare package with fix for you, but we need to know what packages you are using (nxserver –version) on what architecture (x86 or x64) for Arch Linux?

    #24114
    Avatar
    eugenez
    Participant

    NoMachine – Version 6.8.1

    Archlinux x64

    #24169
    Avatar
    eugenez
    Participant

    I can confirm that new patched version of NoMachine works great. Thank you very much!

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.