MacOS Monterey v12.1 server – no audio sound on both Windows/Linux clients?

Forums / NoMachine for Mac / MacOS Monterey v12.1 server – no audio sound on both Windows/Linux clients?

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #36911
    JeZxLee
    Participant

    Hi,

    Running current NoMachine server on macOS Monterey v12.1 desktop.
    On both Windows 11 Pro 64Bit and Manjaro KDE Linux NoMachine Enterprise Client v7.7.4 has no audio sound?
    Any ideas?
    Thanks!

    Jesse

    #36920
    Britgirl
    Keymaster

    Did you get the macOS prompt to approve permissions?

    Try the tips in this article here: https://knowledgebase.nomachine.com/AR01P00962

    If that doesn’t work, also try the procedure here as well: https://forums.nomachine.com/topic/unable-to-get-audio-working-10-14#post-34576

    #36928
    vertico
    Participant

    Hello, I am assisting JeZxLee with this issue.

    All steps have been followed that were provided in the above links. NoMachine S.a.r.l was allowed to load in Security & Privacy ->General

    NoMachine/nxnode has been allowed in Accessibility, Full Disk Access, Screen Recording, Input Monitoring & Microphone

    Here is the kextstat output:

    kextstat | grep nxau
    Executing: /usr/bin/kmutil showloaded
    No variant specified, falling back to release
    142    0 0xffffff7f9a460000 0x3000     0x3000     com.nomachine.driver.nxau (4.1.b2) 78172556-B6A4-3112-BA41-E79D18108476 <126 7 6 3 1>

    Tried re-installing several times, The NoMachine audio output device is still not selectable in Midi Setup (See attached screenshot)

     

    Please let me know

    Attachments:
    #36948
    fisherman
    Moderator

    Hello,

    Can you tell us if you are using new M1 Mac machine?
    Audio does not work on Apple M1 as a server, we have opened new Feature Request to natively support Apple M1, you can see more here: FR12R04054 – Offering NoMachine packages natively built for Apple M1 Chip

    #36952
    JeZxLee
    Participant

    Hi,

    The Mac Mini we are using has an Intel Core i7 CPU.

    Hope we can solve this…

    Jesse

    #36953
    vertico
    Participant

    Hello, it is not an M1.

    It is Mac mini model 2014 Intel i7 3.0GHz 16GB 500GB

     

    Please let me know

    Thank You

    #36993
    fisherman
    Moderator

    About MacOS 12 we have already opened Trouble Report that will be fixed in the following NoMachine versions TR12S10423 – Sound forwarding doesn’t work on macOS 12.

    #37018
    fisherman
    Moderator

    What I noticed is that you can use possible workaround to solve audio problem on Mac OS 12

    sudo rm -rf /Library/Extensions/nxaudio.kext /Library/Audio/Plug-Ins/HAL/NMAudio.driver /Library/Audio/Plug-Ins/HAL/NMAudioMic.driver
    sudo mkdir -p /Library/Audio/Plug-Ins/HAL/
    
    sudo cp -a /Applications/NoMachine.app/Contents/Frameworks/bin/drivers/NMAudio.driver    /Library/Audio/Plug-Ins/HAL/NMAudio.driver
    sudo cp -a /Applications/NoMachine.app/Contents/Frameworks/bin/drivers/NMAudioMic.driver /Library/Audio/Plug-Ins/HAL/NMAudioMic.driver
    
    sudo chmod -R 755 /Library/Audio/Plug-Ins/HAL/NMAudio*
    sudo chown -R "root:wheel" /Library/Audio/Plug-Ins/HAL/NMAudio*
     
    sudo launchctl stop com.apple.audio.coreaudiod
    sudo launchctl start com.apple.audio.coreaudiod
Viewing 8 posts - 1 through 8 (of 8 total)

This topic was marked as solved, you can't post.