Manjaro -> Ubuntu connection problem

Forums / NoMachine for Linux / Manjaro -> Ubuntu connection problem

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #39236
    zawiszaty
    Participant

    I have a problem with connection from Manjaro machine to Ubuntu machine after update Manjaro machine. I can connect to Ubuntu machine but after 1 second I’m disconnected. On Ubuntu machine I see notification about new connection and notification about disconnection. I spot only this kind of error. Reinstallation doesn’t fix my issue 🙁

    /usr/NX/bin/nxplayer –session lpp.nxs

    [1]    120316 segmentation fault (core dumped)  /usr/NX/bin/nxplayer –session lpp.nxs

     

    #39274
    Britgirl
    Keymaster
    #39275
    fisherman
    Moderator

    Can you please execute some commands to collect core stack and send it to us

    coredumpctl list

    You will receive an output like this:

    TIME                          PID  UID  GID SIG     COREFILE EXE                      SIZE
    Thu 2022-07-15 19:48:13 CEST 120316 1000 1000 SIGSEGV present  /usr/NX/bin/nxplayer.bin 2.1M

    then depending on the pid number of the nxplayer crash, please execute:
    coredumpctl gdb 120316 --debugger-arguments="-batch -ex 'thread apply all bt'" > /tmp/crashReport.txt

    then please send us /tmp/crashReport.txt crash report file.

    #39281
    Terrasse
    Participant

    I’m encountered with the same problem.

    Here is my crashReport https://paste.ubuntu.com/p/zDb3k8Ynzk/.

    Attachments:
    #39287
    Britgirl
    Keymaster

    The crash report shows a crash in libnxdixl caused by a call in the nvidia driver. Why this is happening only in Manjaro remains to be seen. For now we suggest you disable hardware decoding on your Manjaro client.

    You can disable it completely in the player.cfg. Please edit the file $HOME/.nx/config/player.cfg and set the configuration key “Enable hardware accelerated decoding” to “disabled”. Before changing the configuration key, you should first quit the NoMachine Player (you can do this by right clicking on the !M icon in the system tray and selecting ‘Quit NoMachine Player’.

    #39291
    Terrasse
    Participant

    It works. Thank you!

    #39293
    Britgirl
    Keymaster

    Update: a similar issue has been reported here https://bugzilla.mozilla.org/show_bug.cgi?id=1758473

    This is a problem with NVIDIA proprietary drivers and not NoMachine. So please, everyone, you can disable HW decoding as suggested in the reply above as a temporary workaround whilst you wait for a fix for the drivers.

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.