NoMachine client disconnects right after connection in latest Manjaro

Forums / NoMachine for Linux / NoMachine client disconnects right after connection in latest Manjaro

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #39220
    sschueller
    Participant

    Hi,

    I just updated to Manjaro Ruah 21.3.3 XFCE from version 21.3.1. After this I can no longer connect to my server (MacOS). The connection gets established but right after connection I am disconnected. I do not see the screen, no error. nxplayer.bin segfaults but I was unable to get any usable trace log.

    Reverting Manjaro back to 21.3.1 XFCE makes it work again. I don’t know if the issue started in version 21.3.2 as I haven’t had that one installed.

    I assume it is something to do with the display? Sadly I am having a hard time finding manjaro change logs between versions.

     

    #39237
    zawiszaty
    Participant

    @sschueller I have the same problem. How you revert manjaro version?

    #39242
    sschueller
    Participant

    If you installed Manjaro with BTRFS you should have timeshift installed which will let you go back to before you updated. Manjaro makes a snapshot just before it makes system changes.

     

     

    #39247
    ericmock
    Participant

    Anyone made any progress on this without downgrading?  Anything from the devs?

    #39253
    gigses
    Participant

    Same problem. No solution found

    #39289
    Britgirl
    Keymaster

    A crash report from another user shows a crash in libnxdixl caused by a call in the nvidia driver. Why this is happening only in Manjaro remains to be seen. For now we suggest you disable hardware decoding on your Manjaro client.

    You can disable it completely in the player.cfg. Please edit the file $HOME/.nx/config/player.cfg and set the configuration key “Enable hardware accelerated decoding” to “disabled”. Before changing the configuration key, you should first quit the NoMachine Player (you can do this by right clicking on the !M icon in the system tray and selecting ‘Quit NoMachine Player’

    #39304
    ericmock
    Participant

    Well, that fixed the crash.  Now I just get a blank (black) screen that won’t close without me killing the process.  Let me know if there’s any way I can help debug this.

    #39313
    Britgirl
    Keymaster

    ericmock, instead of killing the process, grab a backtrace from it:

    gdb -batch -ex "thr apply all bt" -p 12345 > gdb.out

    where 12345 is the . Send us the output.

    #39323
    ericmock
    Participant

    I realize that if I let the player run long enough it seg faults.  However, I’m getting nothing from the backtrace:

    sudo gdb -batch -ex “thr apply all bt” -p 3019189
    Unable to attach: program terminated with signal SIGSEGV, Segmentation fault.

    #39340
    Britgirl
    Keymaster

    Backtrace is empty because the process isn’t running any more. Please follow the instructions from https://forums.nomachine.com/topic/manjaro-ubuntu-connection-problem#post-39275.

    Run

    coredumpctl list

    You will receive output like this:

    TIME                          PID  UID  GID SIG     COREFILE EXE                      SIZE
    Thu 2022-07-15 19:48:13 CEST 120316 1000 1000 SIGSEGV present  /usr/NX/bin/nxplayer.bin 2.1M

    then depending on the PID number of the nxplayer crash, please execute:

    coredumpctl gdb 120316 --debugger-arguments="-batch -ex 'thread apply all bt'" > /tmp/crashReport.txt

    then please send us /tmp/crashReport.txt crash report file.

    In our example the PID is 120316. You will have a different PID number for the nxplayer process. Please use the PID number that you see in your output of coredumpctl list.

    #39342
    ericmock
    Participant

    The core dump is attached.  I also got the following when running it.

    coredumpctl gdb 2812324 –debugger-arguments=”-batch -ex ‘thread apply all bt'” > /tmp/crashReport.txt
    warning: Can’t open file /memfd:pulseaudio (deleted) during file-backed mapping note processing
    warning: .dynamic section for “/usr/lib/libnss_resolve.so.2” is not at the expected address (wrong library or version mismatch?)

    Attachments:
    #39354
    samueldy
    Participant

    I am also on Manjaro 21.3.4 Ruah and have exactly the same issue. I’ve attached my coredump, but did not get any errors when generating it.

    Attachments:
    #39384
    samueldy
    Participant

    Just want to report that I’m still having this issue as of Manjaro 21.3.5. The workaround of disabling hardware-accelerated decoding does not work on my system. I’ve attached my config file and the latest core dump.

    Here are my nvidia and kernel, and OS versions:

    $ pacman -Qs nvidia
    local/conky-lua-nv 1.11.5-2
        An advanced system monitor for X based on torsmo with lua and nvidia enabled
    local/egl-wayland 2:1.1.10-1
        EGLStream-based Wayland external platform
    local/lib32-libvdpau 1.5-1
        Nvidia VDPAU library
    local/lib32-nvidia-utils 515.57-1
        NVIDIA drivers utilities (32-bit)
    local/libvdpau 1.5-1
        Nvidia VDPAU library
    local/libxnvctrl 515.57-1
        NVIDIA NV-CONTROL X extension
    local/linux515-nvidia 515.57-6 (linux515-extramodules)
        NVIDIA drivers for linux
    local/linux518-nvidia 515.57-8 (linux518-extramodules)
        NVIDIA drivers for linux
    local/mhwd-nvidia 515.57-1
        MHWD module-ids for nvidia 515.57
    local/mhwd-nvidia-390xx 390.151-2
        MHWD module-ids for nvidia 390.151
    local/mhwd-nvidia-470xx 470.129.06-1
        MHWD module-ids for nvidia 470.129.06
    local/nvidia-utils 515.57-1
        NVIDIA drivers utilities
    local/xf86-video-nouveau 1.0.17-2 (xorg-drivers)
        Open Source 3D acceleration driver for nVidia cards
    $ uname -a
    Linux cheme-gala 5.18.12-3-MANJARO #1 SMP PREEMPT_DYNAMIC Sun Jul 17 14:33:15 UTC 2022 x86_64 GNU/Linux
    $ lsb_release -a
    LSB Version:    n/a
    Distributor ID: ManjaroLinux
    Description:    Manjaro Linux
    Release:        21.3.5
    Codename:       Ruah
    
    
    #39387
    Britgirl
    Keymaster

    This problem is with the nvidia drivers and not by a NoMachine bug. The same problem was also found in Firefox. They worked around the problem by removing the calls completely. https://bugzilla.mozilla.org/show_bug.cgi?id=1758473

    This does not mean that NoMachine can apply the same workaround. But our own tests show that disabling HW decoding in the player.cfg stops the segfaults. ie.

    Edit the file $HOME/.nx/config/player.cfg and set the configuration key “Enable hardware accelerated decoding” to “disabled”. It’s important to disable this way to prevent the loading.

    You could perhaps write on the nvidia forums and check there whether they have a workaround.

     

    #39389
    ericmock
    Participant

    Do you mean “disabled” or “false”?

Viewing 15 posts - 1 through 15 (of 19 total)

This topic was marked as solved, you can't post.