No audio transfer macOS 10.14.4

Forums / NoMachine for Mac / No audio transfer macOS 10.14.4

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #22242
    Avataristation
    Participant

    macOS 10.14.4 & NoMachine 6.6.8

    No audio transfer from server to client.

    No request for access to microphone in privacy setting

    Have nxnode in accessibility & NoMachine in full disk access & accessibility privacy settings

    Any ideas?

    This used to work before and i used to see an audio driver in sound settings but no longer ion a fresh install

    #22245
    AvatarBritgirl
    Keymaster
    #22246
    Avataristation
    Participant

    It never requests access to microphone tried on two different machines now and tried the re-install.

    Already tried the nxnode app in accessibility.

    Tried most options i could find on the forum

    #22250
    Avatarmkub
    Participant

    Hi istation,

    Make sure, that you chose proper nxnode. Follow the paragraph: How to configure the Mac manually

    https://www.nomachine.com/AR10P01001

    Is it possible to turn on the microphone in the Microphone Section or maybe the field is grayed?

    You can check if the kernel module is loaded with command:

    $ kextstat | grep nxau

    the output should be similar:

    116 0 0xffffff7f80fcd000 0x5000 0x5000 com.nomachine.driver.nxau (4.1.b2) 78172556-B6A4-3112-BA41-E79D18108476

    Thanks,
    mkub

    #22257
    Avataristation
    Participant

    So it doesn’t prompt for mic access on install and there is no way to add retrospectively, see below

    if I run this command kextstat | grep nxau I don’t get an output.

    This is a fresh install on two new Macs both do the same thing

    #22267
    Avatarmkub
    Participant

    It seems like there is a problem with loading KEXT, by system utilities. To resolve this case, call:

    kextutil /System/Library/Extensions//nxaudio.kext

    After it is done, in order to approve the KEXT, access the System Preferences -> Security & Privacy -> General panel on your Mac and click on the ‘Allow’ button (see attachment).

    (To get more information, follow this article https://www.nomachine.com/AR01P00962)

    Then you need to restart nxserver with command:

    /etc/NX/nxserver --restart

    Did you upgrade your operating system? If yes, which was your previous version? Logs would be useful. Please follow the guidelines here: https://www.nomachine.com/AR10K00697.

    Please send them to forum[at]nomachine[dot]com making sure to reference the title of your topic in the subject.

    Thanks,
    mkub

    #22282
    Avataristation
    Participant

    Those commands resolved the problem. Tested on two machines both working.

    Thank you for your support

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.