No hardware sound on server

Forums / NoMachine for Linux / No hardware sound on server

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #33675
    Avatarpaai
    Participant

    Two Kubuntu 18.04 machines with the free NoMachine – Version 7.5.2. The server machine has an HDA NVidia sound system. Stand-alone, i.e. without Nomachine installed, sound works. System Settings shows ‘Built in Audio Analog Stereo’ as expected

    But… when I install NoMachine on that server, in System Settings the line ‘Built in Audio Analog Stereo’ is greyed out and three more choices appear: two ‘NoMachine ouput’ lines and one ‘Simultaneous output to NoMachine output’.

    I can stream sound between the computers with Nomachine installed OK.

    I have an amplifier attached to the line-out of the server. So I have the checkbox ‘mute audio on server’ unchecked. This has worked without problems for a few years. But all of a sudden it seems that NoMachine kills the regular ‘Built in Audio Analog Stereo’ because whatever I do no sound comes into the amplifier. If I uninstall NoMachine from the server, the amplifier works again.

    Thank you for reading this.

    #33681
    Avatarpaai
    Participant

    (I copied this from ths thread “no audio on two Ubuntu 18.04 machines”  after opening this thread, to keep the subjects clean)

    Hi Paai,
    so you mean that you don’t get audio in amplifier during NoMachine session, yes? or it stops working just after installing NoMachine , without using NoMachine session?

    NoMachine doesn’t “kill/stop” default sinks/source that’s why NoMachine use its own sink/sources.

    Please upload logs (instruction is the same how I advised Dan)

    Just while you will be connected to the host machine using NoMachine, please try to check/uncheck “mute audio on server” option a few times.

    Also provide output of commands of pactl on host machine before you connect using NoMachine and upload screen of pavucontrol output device tab.

     

    #33693
    Avatarpaai
    Participant

    OK, I emailed the logs and the pactl output with as subject “No hardware sond on the server”. I also kept toggling the ‘mute audio on server’ checkbox as I have done for the last week.

    Paai

     

     

    #33696
    Avatartsotne
    Participant

    Hi Paal again.

    after you enable logs on the machine, please restart nxserver (if not it miss some essential logs):
    sudo /etc/NX/nxserver --restart

    and after this connect to the machine using NM and collect logs again.

    According to pactl output our sinks/sources are loaded how it should but indeed not see hardware sink/source is weird.
    Can you give use to the same pact commands on host machine (directly on it without using NM) and can you confirm that it is happening only during the session or after NM installation it disappears?

    pavucontol screens would be helpful too.

    #33701
    Avatarpaai
    Participant

    Data are on its way by email. Hope it arrives as there are three logfiles attached: the first 'sudo /etc/NX/nxserver --debug --collect' was executed twicefor some reason . The pavucontrol screens contain the exact same information as the System Settings: two  ‘NoMachine outputs’ and one ‘Simultaneous Output to NoMachine Output’.

    Thanks.

     

    #33708
    Avatartsotne
    Participant

    Hi Paai again, received your logs.

    So according to the logs you are using NoMachine virtual session and “mute server” option is only available for NoMachine physical session (there is no problem in virtual session logs).

    #33751
    Avatarpaai
    Participant

    Dear Tsotne,

    as far as I know, only physical sessions are possible on the free NoMachine, and indeed, the connection properties say ‘Physical session’.

    However, your post set me thinking and I climbed up the attic where the server lives, and the attached monitor still was live for some reason. I disabled the monitor, rebooted the server and now I have sound. The logic is not clear, but I am happy to have my music back.

    Thank you again.

    paai

     

    #33781
    Avatartsotne
    Participant

    Hi Paai,
    glad to hear that your problem is solved now.

    #33788
    Avatarpaai
    Participant

    Still not out of the woods.  Even when het monitor is disabled, some reboots make the sound disappear, and some are all right. All reboots report a physical desktop, but I know that there is another NM session flapping around invisibly, because on powerup, when I try to start, e.g. a firefox window,  the Kubuntu desktop says ‘another Firefox session is active’.

     

    #33795
    Avatarpaai
    Participant

    The problem seems to be that there are two NM sessions. On the server runs display :0. On the client runs display echo $DISPLAY
    :1002

    Is there a way to force the NM client to attach to display :0 in stead of creating a new display?

     

     

     

     

    #33804
    Avatartsotne
    Participant

    Hi Paai,

    In general, NM connects always to the physical session, but the physical session should exist on the system, NM just detects and connects to it, if on the system the physical session is not detected NM creates a virtual session, to be sure that you will be able to use it (that’s happening in your case, a possible reason can be that system is slowly booting).

    And also, please check /usr/NX/etc/server.cfg file and if CreateDisplay key is set to 1, set it to 0 and restart NM:
    sudo /etc/NX/nxserver --restart

    #33811
    Avatarpaai
    Participant

    Hi Tsotne,

    it may be too early to declare success, but setting the CreateDisplay key certainly had an effect. Restarting the server made it come up with the hardware audio enabled. Cycled through it a few times and the change seems to be permanent. Still, I wonder what caused it in the first place.

    So if you don’t hear from me, the problem is solved.

    Thank you again.

    Paai

     

     

    #33815
    Avatartsotne
    Participant

    Hi again,
    glad to hear that it helped.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.