Not getting public IP

Forums / NoMachine for Windows / Not getting public IP

Tagged: 

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #27312
    Avatararlesterc
    Participant

    Howdy.  I have the latest Community Edition of NoMachine – downloaded today – and am running it on Windows 8.1.  I have a Dlink DIR 645 router.  I have a dynamic Public IP but it’s been the same for years.    I am able to remote control within the office no problem  – the host will show it’s local IP and the other computer in the office will see it and be able to take remote control of it.  However the host never shows an Internet IP.  The Dlink DIR 645 has  UPNP option and I have it enabled.  From my understanding the community edition should be able by default to figure out the public IP I have – the same one that shows up in Whatsmyip.

     

    I reviewed this previous post with a similar problem:

    https://forums.nomachine.com/topic/failed-to-map-the-port-on-d-link#post-24387

     

    I did the same things as you instructed the poster on that link:

    +++++++++++++++++++

    Can you find the line: NXUPnPPort 27468 in the server.cfg and comment it out by adding # on the beginning? Then do from a terminal:

    "c:\Program Files (x86)\NoMachine\bin\nxserver" --restart
    "c:\Program Files (x86)\NoMachine\bin\nxserver" --upnpmap

    The output should look like this:

    Local IP 10.0.1.2
    Gateway IP 10.0.1.1
    External IP 11.222.333.444
    NX port 4000 mapped to: 11.222.333.444:23484

     

    ++++

    I got no output at all when I ran the command.

    I have also tried  putting a port forward rule in the Dlink so that port 4000 is directed to the appropriate internal IP. I disabled all other port forward rules.  I also #’d out the lines in server.cfg that did the same thing.  I tried it with it left in as well.  I have tried pretty well all combinations.

    I also tried this command –

    nxserver –upnpstatus

    Output was the local IP of the computer and the gateway of the computer but no public IP.

    Also I do not fully understand this article:

    +++++++++++++++

    https://www.nomachine.com/TR12N07384

    “Server settings option to enable port mapping is not correctly checked”

    The port checkbox is not checked when the server says the port is not mapped. This behaviour is wrong, because the port may be mapped later. The GUI should always report the CFG status (so if the CFG says that the port must be mapped, the checkbox must be checked).

    In addition, the port being shown in the GUI can be different to the port mapped by the server, this behaviour is incorrect, as it should be the same.

    When UPnP is enabled, in the client’s address welcome page, the IP assigned with that UPnP port should be shown, in this dialog with the welcome page, a new line is added instead of just having the one related to that IP/ port combination.

    +++++++++++

    And I also don’t understand the  concept behind this post:

    https://forums.nomachine.com/topic/problem-mapping-gateway-port#post-18936

    What is mapping a gateway port mean? How would I do it with my Dlink 645?

    Finally one other item that may be of interest is that I have used [removed] on the very same computer and it properly displayed the public IP (again a dynamic IP provided by my ISP that has remained the same for years) and I was able to connect to it over the Internet.

    Your attention and assistance on this is appreciated in advance,

     

    #27343
    Avatarkroy
    Contributor

    Which version NoMachine version do you have installed? Is the machine was rebooted after installation? Did you tried to connect there from the local network?

    Please check if EnableUPnP in server.cfg is uncommented and set to NX:

    EnableUPnP NX

    You can try also Port Forwarding to connect from outside local network. There is a lot instruncions for your router model (https://portforward.com/d-link/amplifi-dir-645/ https://openmyip.com/DLink-Amplifi-DIR-645-router-setup). Reserve IP for your Windows machine, and then set Port Forwarding for that IP with TCP and UDP port 4000.

    #27363
    Avatararlesterc
    Participant

    Dear Kroy:

    Thanks for quick reply.  Can you please respond  using  the point numbers I have used wherever possible  – I have 6 points and I would like to have them addressed per point if there is a further info, query to be provided in regard to them.

    +++++++++++

    1)

    Which version NoMachine version do you have installed? Is the machine was rebooted after installation? Did you tried to connect there from the local network?

    I wrote that I downloaded just the other day.  It was NoMachine 6.9.2_1.  I also wrote that I was able to successfully connect locally.  I rebooted system and router many times.

    +++++++++++

    2)

    Please check if EnableUPnP in server.cfg is uncommented and set to NX: -   

    Yes it is.  I also tried with it commented out and port forward put in router.  See further detail at point 3 below.

    ++++++++

    You can try also Port Forwarding to connect from outside local network. There is a lot instructions for your router model (https://portforward.com/d-link/amplifi-dir-645/ https://openmyip.com/DLink-Amplifi-DIR-645-router-setup). Reserve IP for your Windows machine, and then set Port Forwarding for that IP with TCP and UDP port 4000.

    3) I tried port forwarding and tried all the other things in the similar post and all combinations thereof – commenting out and port forward settings in router, leaving uncommented and setting port forward in router, etc. etc.  I know port forwarding works as I successfully use it for other applications.

    I covered this in my original post as well:

    “I have also tried  putting a port forward rule in the Dlink so that port 4000 is directed to the appropriate internal IP. I disabled all other port forward rules.  I also #’d out the lines in server.cfg that did the same thing.  I tried it with it left in as well.  I have tried pretty well all combinations.”

    I also wrote this:

    “Finally one other item that may be of interest is that I have used another remote control program  on the very same computer and it properly displayed the public IP (again a dynamic IP provided by my ISP that has remained the same for years) and I was able to connect to it over the Internet.”

    +++++++++++++

    4) When you write:

    Reserve IP for your Windows machine, and then set Port Forwarding for that IP with TCP and UDP port 4000.

    What does that exactly mean?  How do I reserve? As i wrote, I have a dynamic public IP provided by my ISP that has stayed the same for years.

    +++++++++++

    5)

    The following point I raised  was not addressed:

    Also I do not fully understand this article:

    +++++++++++++++

    https://www.nomachine.com/TR12N07384

    “Server settings option to enable port mapping is not correctly checked”

    [snipped, refer to Trouble Report]

    6) This part of the post was also not addressed:

    And I also don’t understand the  concept behind this post:

    https://forums.nomachine.com/topic/problem-mapping-gateway-port#post-18936

    What is mapping a gateway port mean? How would I do it with my Dlink 645?

    My assumption is that mapping a gateway port is different than port forwarding – please distinguish.

    Thanks in advance for your continued assistance.

    #27376
    Avatarkroy
    Contributor

    First two points are clear.

    Point 3)

    I tried port forwarding and tried all the other things in the similar post and all combinations thereof – commenting out and port forward settings in router, leaving uncommented and setting port forward in router, etc. etc. I know port forwarding works as I successfully use it for other applications.

    Port Forwarding rules won’t display in the command –upnpstatus output or on “Welcome windows” in the NoMachine Player, but a connection should still be possible. Please try to connect using Public IP and port 4000 if you have configured port forwarding rules on the router.

    Point 4)

    What does that exactly mean? How do I reserve? As I wrote, I have a dynamic public IP provided by my ISP that has stayed the same for years.

    When I wrote “reserve IP on the router for your Windows machine” I wasn’t referring to the public IP. I meant the local IP of your Windows machine, and it’s for the port-forwarding rules on your router. Port Forwarding will work if you open port for the defined local IP. If on Windows there is no static IP, the local IP can change and you will lose the possibility to connect there.

    #27380
    AvatarBritgirl
    Keymaster

    I will answer for points 5 and 6

    Point 5)

    Also I do not fully understand this article:

    https://www.nomachine.com/TR12N07384

    That Trouble Report is nothing to do with manual port-forwarding on the router. It’s referring to the GWPort box in the server GUI Services panel which is not being flagged correctly. In this panel the port that NoMachine server has automatically chosen to allow connections to the computer over the Internet is printed. See our Server Guide, specifically section 2, (see the guide here: https://www.nomachine.com/DT10O00155#2.1.)

    Point 6)

    And I also don’t understand the concept behind this post:

    https://forums.nomachine.com/topic/problem-mapping-gateway-port#post-18936

    The topic you mention is also not your case. In that particular topic, the user was having issues with changing the port in the Services panel of the server GUI, mentioned in point 5. That user wanted to change the port of a particular computer to his preference. The message returned was “Failed to map the port on the Gateway” in his case.

    NoMachine works like this. NoMachine tries to use UPnP to carry out port-forwarding on its own. When NoMachine starts, it automatically selects and maps certain ports to prepare for outside access. If you want, you can change the port (GWPort) to something more memorable to allow connections from the outside (see the same guide mentioned above). This is the port which shows up in the Welcome Panel when opening NoMachine on the server.

    On some occasions, NoMachine can’t enable UPnP on its own for whatever reason, and it’s necessary to intervene manually on the router. In this case, you change nothing in the UI of NoMachine and any intervention is only done on your router according to the instructions for port-forwarding of your specific router.

    As for point 1) I’d just like to add that when a user doesn’t specify the actual version in numbers, it’s standard practice that we ask just to make sure. The community edition you refer to I imagine is the free version and that you downloaded it from our website.

    I reviewed this previous post with a similar problem:

    https://forums.nomachine.com/topic/failed-to-map-the-port-on-d-link#post-24387

    We test NoMachine in a multitude of set-ups with multiple types of routers as well, but we can’t for obvious reasons test with every router available on the market. This particular user had a problem with an old D-link router which was proving difficult to configure. Replacing it solved the connectivity issues.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.