Problems connecting to one remote computer

Forums / NoMachine for Windows / Problems connecting to one remote computer

This topic contains 10 replies, has 4 voices, and was last updated by Avatar Britgirl 2 months, 3 weeks ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #23302
    Avatar
    YourCall
    Participant

    Hi all,

    I have two remote computers (Windows 10) that I had been using [other tool] to access, but they’re now insisting they I pay them a licensing fee so I decided to move over to NoMachine.  The computer I am connecting from (this one) is also Win10.

    Both computers I am trying to remote into were bought at the same time and set up (AFAIK) identically.  They are miles from me, though, and we are connecting over the internet.

    One computer took the NoMachine flawlessly and is perfectly (so I understand “the basics” of how to set things up!) while the other gives me “A connection timeout has occurred while trying to connect to ‘10.1.10.10’ on port ‘24564’. The issue could either be caused by a networking problem, by a firewall or NAT blocking incoming traffic or by a wrong server address. Please verify your configuration and try again.” any time I try to connect.

    The firewall is the baked-in Windows one — and I have it set to let through all of the “NX” entries in the list.  The server address is what NM itself tells me it is supposed to be (I have quintuple checked).  I can still log in with [other tool] (for five minute intervals, gr), so I don’t think the other two error cases apply?

    At a real loss of what to do next.  Any thoughts?

    Thanks!

    #23322
    Avatar
    Bilbotine
    Keymaster

    Hello YourCall,

    Can you please send us the logs of the problematic Windows machine, it will provide us more information. You can send them to forum(at)nomachine(dot)com, making sure you reference the topic as subject.

    If needed, the procedure to gather logs is explained here: https://www.nomachine.com/DT10O00163

    #23352
    Avatar
    kroy
    Contributor

    Hi,

    Are you trying to connect with enabled UPnP or did you forward the ports manually? You can find information about how to connect when the server is behind a firewall or NAT router here: https://www.nomachine.com/AR11L00827.

    Please verify if the IP which you are trying to connect to is indeed that Windows server public IP (for example there: https://www.whatismyip.com/). If not – it indicates that you have a double NAT networking. Which means that NoMachine has to go through two or more routers. In that case you need to set up separate port forwarding rules on each device.

    It will be possible to skip these steps with NoMachine Network feature (https://www.nomachine.com/FR07J02731) which is coming soon.

    #23354
    Avatar
    YourCall
    Participant

    Hi,

    I did forward the logs to the email address listed above by Bilbotine.

    As for Kroy’s response: I’m just a fairly dumb user, so I’m really not sure about most of the terminology that’s being used here (and even looking these terms up still isn’t precisely clear)… but AH-HA! using that IP finding link above it appears that the IP for that computer is a “IPv6” and not “IPv4”. (I have noted the long long string, for later)

    What, exactly, I need to do with this information isn’t clear to me, however?

    Can someone explain it like I am five?

    #23361
    Avatar
    Bilbotine
    Keymaster

    Hi YourCall,

    We apologise if the previous explanations were not clear enough.

    Thank you for the logs; I shared them with Kroy. But since they are logs from client side only, they didn’t help us find out what the problem is.

    Based on what you describe, it seems to be a network configuration problem.

    We guess that the UPnP is enabled, which should be enough to connect.

    All IP verification should be done on the server side. If the public IP you get from the finding IP website is not the same as the public IP in the NoMachine Player window: this is a problem. Can you try to forward the port on the router manually ? (see the article “How to connect to NoMachine when the server is behind a NAT router or a firewall”: https://www.nomachine.com/AR11L00827)

    Just to check: did you use the instructions from “Getting started with NoMachine” (https://www.nomachine.com/getting-started-with-nomachine) ? If not, please have a look as they might be helpful.

    #23365
    Avatar
    YourCall
    Participant

    I honestly don’t mean to be a problem, but when I say “explain it like I am five”, I really mean that.

    As noted, I successfully set up NoMachine on one of my two machines that I am trying to remote into.  It works GREAT!  But it’s the second computer that is giving me problems.

    I recognize all of the words of ” Can you try to forward the port on the router manually” but I don’t actually understand the HOW of it.  When I follow your “How to connect link” I see an instruction there of

    *****

    If you using NoMachine (free), edit the server configuration  file (namely server.cfg) and set:

    EnableUPnP NX        for users connecting with the NX protocol

    Then restart NoMachine.

    *****

    But what on earth does “set” mean in this context?  “EnableUPnP NX” does NOT have a “#” in front of it in the server.cfg file, so that makes it “set”? Is that right?  (Honestly: I don’t know!)  It *looks* right to me  (on BOTH computers, too)

    [I’m not even truly sure which way we’re using “client” and “server” here — the server is the computer that is trying to initiate the contact, and the client is the computer you’re trying to log in to, correct?  Because the log I sent *was* from the initiating computer, not the “client”]

    As I noted, the link Kroy mentioned to find the IP didn’t result in a “IPv4” result of “10.1.10.10:24564” that NoMachine on the remote computer told me was the IP — it gave me a “IPv6” result of “2603:3024:1e02:c2f0:8d60:74d0:393f:afab”.  But I don’t know what I am meant to be doing with that?

    Basically: not sure what my next step is here.

    #23367
    Avatar
    Bilbotine
    Keymaster

    Hi YourCall,

    Let me try to summarise from the beginning 🙂

    NoMachine allows to access another computer using an IP address. The host machine has two IP addresses: a private IP address assigned to the computer and a public IP assigned to the router. If you connect to the NoMachine Server over the internet, you are actually connecting to the router, which must then forward this connection to the host machine. Please refer “Using NoMachine for remote access to a computer over the internet” section from the website https://www.nomachine.com/getting-started-with-nomachine  to get the public IP from remote host.

    Instruction from the website should be enough to connect. But if there is a problem, you need to verify if your remote public IP displayed on the NoMachine Player is the same as displayed on https://www.whatismyip.com/ in the “Your Public IPv4 is” section. If the IP is different – connecting over the Internet will require manual configuration of the host computer’s firewall and router.

    If those options are not possible, what you need is NoMachine Network (https://www.nomachine.com/FR07J02731) which is coming soon.

    #23371
    Avatar
    YourCall
    Participant

    “connecting over the Internet will require manual configuration of the host computer’s firewall and router.”

    Can someone describe how to do this?

    #23387
    Avatar
    Bilbotine
    Keymaster

    Hello YourCall,

    Can you please check your public IP (not ipv6), and tell us if it’s different than the one displayed in the bottom of the NoMachine window (like on the getting started window) ?

    If it’s different, it could be a double Nat configuration. Which means that you have two routers. One is facing the internet and one is on your local network. In this case, you need to set port forwarding on both (you can also find guidelines on the internet, for example from there: https://portforward.com/router.htm).

    It is possible that the first router is from your provider, so you need to ask your Internet Service Provider to forward the port for your router IP.

    Can you also send us the output of these commands, to allow us to verify if UPnP is enabled:

    "C:\Program Files (x86)\NoMachine\bin\nxserver.exe" --upnpmap
    
    "C:\Program Files (x86)\NoMachine\bin\nxserver.exe" --upnpstatus
    #23397
    Avatar
    YourCall
    Participant

    Last thing first:

    C:\Users\Ocean 2>”C:\Program Files (x86)\NoMachine\bin\nxserver.exe” –upnpmap
    NX> 500 ERROR: Only a user with administrative privileges can use option: upnpmap.

    C:\Users\Ocean 2>”C:\Program Files (x86)\NoMachine\bin\nxserver.exe” –upnpstatus
    Local IP                   192.168.1.115
    Gateway IP                 192.168.1.1
    External IP                10.1.10.10
    NX port 4000 mapped to:    10.1.10.10:24564

     

    Using the link you provided above, I only got an IPv6 returned to me, but I thought to google search alternatives and found some that were returning a IPv4 of 67.170.220.172 — so, not a match.

    Still fuzzy on the next step, sorry!

    #23440
    Avatar
    Britgirl
    Keymaster

    As Bilbotine and Kroy suggested earlier, the output that you pasted shows that there is a double NAT set up and port-forwarding will need to be enabled. Please see the answer in this topic: https://forums.nomachine.com/topic/pcs-behind-multiple-routers#post-10084

    Other related topics are:

    https://forums.nomachine.com/topic/redirecting-port#post-18553

    https://forums.nomachine.com/topic/error-138-cant-connect-to-office-computer-from-home

    IMO, the easiest option for you is to wait for NoMachine Network, coming soon, which will eliminate this problem altogether.  It will avoid having to know the remote computer’s public-facing IP address and eliminate the need to configure port-forwarding on the router sitting in front of the computer you want to access.

    Please sign up to receive a notification once this feature is implemented:  https://www.nomachine.com/FR07J02731

Viewing 11 posts - 1 through 11 (of 11 total)

This topic was marked as solved, you can't post.