Session Negotiation failed – running db

Forums / NoMachine for Linux / Session Negotiation failed – running db

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #27425
    Avatarsmacktoid
    Participant

    This morning I was unable to access my remote machine using NoMachine. An error message was immediately presented that read “The session negotiation failed”.

    When I investigated this I found that the error was caused by a failure to inspect a file in the /usr/NX/var/db/limits/{username}. A permissions error was returned saying that the file couldn’t be read.

    When I looked for this file I could see that it didn’t exist. I tried creating a blank file in that location and making it readable, which allowed me to progress to session selection. But now whenever I pick a display to connect to I still get “The session negotiation failed”.

    The error in the logs is now :

    NX> 595 NoMachine server exception: no key selected for table: running. (InfoManager::updateKey).

    Restarting doesn’t fix the problem. The nxserver –list command shows no active sessions. Under the /usr/NX/var/db/running directory there are several entries. I’m wondering if the database is perhaps in a bad state?

    Any suggestions for how to fix this?

    #27441
    Avatarsmacktoid
    Participant

    I ended up taking the latest update (which was released last night). It seems to have cleaned up the state of the NoMachine server.

    I can connect to my remote machine again.

    #27472
    AvatarBritgirl
    Keymaster

    There was an issue with manifest causing a permissions error (for server-side installations), which has since been fixed so it is probable that you downloaded the update after we fixed it 🙂 You shouldn’t get the problem again.

    To change the ownership back to nx, it’s enough to run the command:

    sudo chown -R nx /usr/NX/var/db/limits

    (related topic: https://forums.nomachine.com/topic/session-negotiation-has-failed)

     

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.