Unable to connect from Windows 7 to Ubuntu 18.04

Forums / NoMachine for Windows / Unable to connect from Windows 7 to Ubuntu 18.04

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #25197
    Avatarndavrr
    Participant

    I have downloaded and installed the lastest version of NoMachine on a laptop running Ubuntu 18.04 and a desktop running Windows 7

    In the Linux machine which I want to control, I am getting a display like this: nx://25.90.xx.xx:20564

    I am putting this value of IP address and the port number in the Windows 7 machine in order to access the linux machine. But, I am getting an error message – A connection timeout has occurred.

    #25211
    Avatarbrotech
    Participant

    Hell ndavrr,
    in the NX player on Windows 7 you should use the IP of the ubuntu machine (which I understand you are doing). The port depends on the protocol (not display), for sessions using the NX protocol, the default port is 4000; for SSH connections the port is 22.

    NoMachine Player first connects to the NoMachine server, asks for authorization and then you choose a session to attach to or you create one.

    #25235
    Avatarndavrr
    Participant

    Thank you for your message and help. I am getting a bit confused after reading your message. Does it mean that in the Windows 7 machine I need to put the port number as 4000 and not 20564 (which is the number displayed on the Linux machine).

    #25247
    Avatarkroy
    Contributor

    If it’s your local network – you should use local IP and port 4000 (please take a look: https://www.nomachine.com/getting-started-with-nomachine). External IP and port (in your case 25.90.xx.xx:20564) should be used if you are connecting over internet. If this is your case and there shows connection timeout error it could be some router settings problem.

    Can you check if your router supports UPnP? Please verify also if 25.90.xx.xx indeed is your external IP (for example there: https://www.whatismyip.com/). If not – it looks that you have a double NAT networking. It means that NoMachine has to go through two or more routers. In that case you need to set up separate port forwarding rules on each device. If IP is the same you need to manually configure them: https://portforward.com/help/doublerouterportforwarding.html.

    It will be possible to skip these steps with NoMachine Network feature (https://www.nomachine.com/FR07J02731) which is coming soon.

    #25253
    Avatarndavrr
    Participant

    I appreciate your efforts to try to help me. Thank you for the same.

    NoMachine (NM) is working without any problems whatsoever in my local network. It detects all the machines which have NM installed, automatically and the connections also happen seamlessly. The issue is coming when trying to connect over the internet. Really looking forward to the implementation of the NoMachine Network feature since I have spent many hours and have not met with success so far.

    Can you check if your router supports UPnP? –> Yes it has and it is enabled.

    Please verify also if 25.90.xx.xx indeed is your external IP –> No it is not. https://www.whatismyip.com shows a different value of my IP address. To be more precise. The values of IP adresses detected by NM  and that shown by whatismyip.com are different values. I have really no clue as to why the two addresses are different. Will you be able to throw some light on how this can happen?

    It means that NoMachine has to go through two or more routers –> There is only router. This is the setup:
    Computer <–> Router <–> Internet

    In that case you need to set up separate port forwarding rules on each device –> I have tried to seup the port forwarding rules on the router, but have not met with success. If I share the screenshot of the page of the router (after I login to the router admin portal at 192.168.1.1) where the port forwarding rules are to be setup, will you be able to guide me as to how to do it?

    Thanking all the experts who are trying to help me, once again.

    #25291
    AvatarBritgirl
    Keymaster

    With a double NAT there’s not much you can do. Take a look here: https://forums.nomachine.com/topic/problems-connecting-to-one-remote-computer

    All you can do is wait for NoMachine Network to be released.

    #25303
    Avatarndavrr
    Participant

    Hello Britgirl, I do not think there is a double NAT. As mentioned by me in my earlier post. This is the setup:
    Computer <–> Router <–> Internet

    The values of IP adresses detected by NM and that shown by whatismyip.com are different values. I have really no clue as to why the two addresses are different. Will you be able to throw some light on how this can happen?

    I have tried to set up the port forwarding rules on the router, but have not met with success. If I share the screenshot of the page of the router (after I login to the router admin portal at 192.168.1.1) where the port forwarding rules are to be setup, will you be able to guide me as to how to do it?

    #25316
    AvatarBritgirl
    Keymaster

    This article will help you to discover if you have double NAT or not: https://www.pcworld.com/article/3175739/how-to-identify-and-resolve-double-nat-problems.html. The last section provides some tips which you can follow.

    You can submit your screenshot by all means – please submit it to forum[at]nomachine[dot]com, not here because it will be visible to everyone.

    #25317
    Avatarndavrr
    Participant

    Thank you so much for providing these resources to me. I shall do as directed and shall get back to you with the screenshots through email.

    When I send the email to forum[at]nomachine[dot]com, should I mention any specific reference number so that you can identify my screenshots to this particular issue (and post).

    #25319
    AvatarBritgirl
    Keymaster

    Just ensure you put the title of the topic as your subject 😉

Viewing 10 posts - 1 through 10 (of 10 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.