Wrong keyboard layout on login (azerty needed)

Forums / NoMachine for Linux / Wrong keyboard layout on login (azerty needed)

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #29862
    AvatarSteve92
    Participant

    Hello!

    I’m testing NoMachine (free last release 6.12.3_7_amd64, .DEB file) to acces a VPS under “Debian 10” with LXDE from a “Windows 8.1” client.

    NoMachine gives very good perfomances even with low bandwidth but I meet a very annoying problem with keyboard layout on Debian login page.

    Despite many tests with supposed solutions given on this forum and elsewhere, I always get a “qwerty” keyboard instead of “azerty” (french).

    I’ve tested this with NO SUCCESS:

    In  /etc/X11/xorg.conf
    Add:

    Section “InputDevice”
    Identifier “Generic Keyboard”
    Driver “kbd”
    Option “CoreKeyboard”
    Option “XkbRules” “xorg”
    Option “XkbModel” “pc105”
    Option “XkbLayout” “fr”
    Option “XkbVariant” “latin9”
    Option “XkbOptions” “lv3:ralt_switch”
    EndSection

    “Command localectl set-x11-keymap fr would set the Xorg keyboard layout to French (automatically creating the config file /etc/X11/xorg.conf.d/00-keyboard.conf).”
    => no file created
    Manually create “00-keyboard.conf” with lines:

    Section “InputClass”
    Identifier “system-keyboard”
    MatchIsKeyboard “on”
    Option “XkbLayout” “fr”
    EndSection

    KO ! still have qwerty keyboard. :o(

    …and other tests…

    It’s crazy to spend so much time with a setting that should be very simple !

    I have no problem with [removed], [removed], [removed]…

    I’m very frustrated… What could I do ?

    Thanks in advance.

    Regards,

    Steve.

    #29888
    Avatargraywolf
    Moderator

    Hello.
    I think you encountered the issue described in this topic: Some issue with Keyboard mapping

    and here: Keyboard layout is wrong when sharing a physical desktop which explains that it is not a NoMachine issue.

    #30018
    AvatarSteve92
    Participant

    Hello,

    After many hours of research on the Web, I finally found this solution, at display manager level, to get “azerty” (french) keyboard when login to Debian 10:
    – edit /etc/lightdm/lightdm.conf
    – under the section [Seat:*] add:
    display-setup-script=setxkbmap fr

     

    #Free bonus ! 🙂

    To get an ‘azerty’ keyboard after Debian  login
    in /etc/xdg/lxsession/LXDE/autostart
    add: setxkbmap -layout “fr,fr”

    It seems so simple once you have the solution. :o)

    I hope it will help all people who need “azerty” keyboard ! 😉

    Regards,

    Steve.

    #30022
    AvatarBritgirl
    Keymaster

    Thanks for posting 🙂

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.