mkub

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 39 total)
  • Author
    Posts
  • in reply to: No audio with ALSA on CentOS6 #26369
    Avatarmkub
    Participant

    Hi,

    Alsa doesn’t work on the physical session. To resolve this problem you may need to create different kind of session. Please follow this article for more information.

    https://www.nomachine.com/AR03P00973

    As a second workaround we may suggest to install Pulse Audio.

    in reply to: Audio streaming and microphone forwarding #26325
    Avatarmkub
    Participant

    Hi,

    Check if the NoMachine audio input and output work properly. If so, try to direct the sound from the audio devices to your radio.

    Thanks, mkub

    in reply to: Audio streaming and microphone forwarding #26290
    Avatarmkub
    Participant

    Hi,

    Are you able to hear the radio on the remote machine, physically? NoMachine connects to the default output and input of the machine. There is no option to customize it. You can try to set your radio as a default audio device before establishing the session. Then, when you connect to the machine, radio will be your sink and source. Please remember to enable microphone during session.

    in reply to: Linux audio delay #26286
    Avatarmkub
    Participant

    Hi,

    At first, you can try to decrease the audio quality in audio settings and verify if delay get improved. Sometimes, reducing system loads works too. Next step would be to verify settings of server’s audio framework. May anything cause conflicts?  Do you use Phonon framework? Do you use any additional software to maintain sound? Is decreasing video quality make any difference in terms of the sound?

    Maybe there are some problems with pulseaudio. Try to kill it and respawn, then restart NoMachine server.

    pulseaudio -k; pulseaudio -D; sudo /usr/NX/bin/nxserver --restart

    in reply to: Can’t share local SUBST #25970
    Avatarmkub
    Participant

    Hi,

    If you try to modify reserved files, the operation will end with the message ‘access denied’. This also applies to deleting files. About the reason you cannot see your new virtual disk – we don’t map each disk separately. It means, when the virtual disk path points to C:\XFER, then it’s considered as a part of C:\. Try to execute SUBST X: C:\ instead.

    Thanks,
    mkub

    in reply to: Error mounting samba shared drives on virtual session #25790
    Avatarmkub
    Participant

    Hi,

    It looks like the disk wasn’t mounted by SMB before an attempt to mount it by NoMachine. Can you make sure, that the disk is present in your environment? It is also possible that SMB mounts the disk after starting the file browser.

    Let’s consider 3rd point mounting failed. Are you able to mount the disk by NoMachine, after some time, in the next try. First and failed try shouldn’t block such possibility.

    If the SMB has mounted the disk and still you’re unable to use it with NoMachine, please submit the logs to forum[at]nomachine[dot]com. For instructions, see here: https://www.nomachine.com/AR10K00697.

    Thanks.

    in reply to: NoMachine audio still not working in Catalina #25760
    Avatarmkub
    Participant

    Hi,

    Can you validate audio devices? Remote audio output should be set to NoMachine Audio Adapter but local to the physical device. What about kext? Is it mounted? You can verify this using the Terminal sudo kextstat | grep nx. The output should contain “com.nomachine.driver.nxau”.

    What’s more you can check if kext is approved. To do this: open the System Preferences -> Security & Privacy -> General panel on your Mac and click on the ‘Allow’ button, if exists, and then restart nxserver with /etc/NX/nxserver --restart. For more information: https://forums.nomachine.com/topic/no-audio-from-macbook-air-to-imac#post-21148.

    Thanks,

    mkub

    in reply to: Problem to access a remote disk #25661
    Avatarmkub
    Participant

    Hi,

    Thank you for logs. As a temporary solution we may suggest uninstalling antivirus. In a meantime our lab will investigate the problem.

    in reply to: Problem to access a remote disk #25640
    Avatarmkub
    Participant

    Hi,

    Do you have any antivirus installed? If so, which program is it? Can you try to disable it and then try to mount remote disk again? Could you also send mini dump generated by the operating system? By default they should be located in C:\Windows\minidump. Please send them to forum[at]nomachine[dot]com using the title of that forum’s thread as the mail’s subject.

    Thanks

    in reply to: Support for Catalina? #24475
    Avatarmkub
    Participant

    Was the driver installed, after the fresh installation? You can check it with command kextstat | grep nxa. The output should be similar:

    165    0 0xffffff7f83a49000 0x5000     0x5000     com.nomachine.driver.nxau (4.1.b2) 78172556-B6A4-3112-BA41-E79D18108476 <90 6 5 3 1>

    Verify its path using kextfind -b com.nomachine.driver.nxau, it should point to /Library/Extensions/nxaudio.kext.

    If the driver exists and still, there is no sound, you should check NoMachine permissions in Settings ->  Security & Privacy -> Privacy. Verify if NoMachine and its processes have granted proper permissions using article from my previous post.

    No output means that the driver wasn’t installed properly. As a workaround you can try to install it manually. But first you need to change permissions of nxaudio.kext, as in the example:

    chmod -R 755 /Library/Extensions/nxaudio.kext
    
    chown -R root:wheel /Library/Extensions/nxaudio.kext

    and then

    kextload /Library/Extensions/nxaudio.kext

    In your previous post you didn’t add ‘-R’ flag to ‘chown’ command.

    About lack the sound after update. If the permissions are proper then I can suggest to uninstall NoMachine and install it again. We’re trying to understand the issue.

    in reply to: Support for Catalina? #24467
    Avatarmkub
    Participant

    Did you follow the article below? After adding proper permissions’ audio should work.

    https://www.nomachine.com/AR10Q01057

    in reply to: No audio on HMDI Raspberry Pi 3+ #24345
    Avatarmkub
    Participant

    Hi,

    Make sure you choose the correct output according to the article below: https://www.raspberrypi.org/documentation/configuration/audio-config.md

    What’s more, you can use PulseAudio Volume Control which helps in configuration. Check if HDMI is the default audio output.

    in reply to: No sound from Catalina #23733
    Avatarmkub
    Participant

    Probably, there are some problems with granting appropriate permissions.

    Thanks,

    mkub

    in reply to: No sound from Catalina #23712
    Avatarmkub
    Participant

    Hi,

    The problem is caused by the bug in the macOS Catalina Beta. For now, it is impossible to stream audio from this operating system. However, if you want to use NoMachine as a Client and stream audio from other machines you can use workaround. Open terminal and type:

    /Applications/NoMachine.app/Contents/MacOS/nxplayer and then establish connection to the desired machine. Audio should work properly.

    in reply to: Unable to hear forwarded microphones #23464
    Avatarmkub
    Participant

    Can you tell us a bit more about your scenario?

    NoMachine Microphone feature is based on inputs’ audio devices. On the Client side, as an input, you should have set a physical device, which from what you have written I assume you have done. On the Server side it should be NoMachine Microphone Adapter.

    Forwarding the mic from the client to the server allows the user to use a remote side app (like Skype for example or some app in which you want to record your voice). Another important thing, there is no loop back from the microphone with NoMachine. That means you won’t be able to hear the microphone directly, but the application using the microphone will. For example: using Skype in a call to someone from the remote computer. Your colleague or friend will hear your voice on their computer, your voice will not be heard on the computer where your Skype session is running.

    You can make a quick test during NoMachine connection by pointing your remote browser to this website after you’ve forwarded the client-side mic to the server.

    https://www.onlinemictest.com/

    Your browser will detect mic, despite you not being able to hear it.

Viewing 15 posts - 1 through 15 (of 39 total)