nxmac

Forum Replies Created

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • nxmac
    Participant

    Well, I just tried to connect with NoMachine player and couldn’t again.  The icon is gone again, and while the issue still seems similar, it appears that perhaps Big Sur 11.6 has made it worse.  This time command+q definitely was not involved and I wasn’t connected to begin with when the Mac went to sleep.  Also different: by the time I noticed the issue, I was presented with the second error message after a long connect attempt (normal for the second error message, basically it’s timing out) without any prior action on the Mac.

    nxmac
    Participant

    Follow-up to my previous post…  I wanted to clarify that while I am not certain if the command+q behavior is a bug, I do believe that the stuck icon in the dock is a bug.  To be clear, my dock preferences have “Show recent applications in dock” disabled, so it is showing the “running application” icon as opposed to a “recent application” icon.  This is why I use command+q to get rid of that icon.  To elaborate, I believe the designed behavior is for the icon to only be shown in the menu bar as is the case immediately after installation or reboot.  I also know my expected (/ presumed designed) behavior is possible because KeePassXC performs that way.  It is always shown in the menu bar, but when a window is visible, it is shown in the dock, and when that window is closed (red x in top left of window), the icon disappears from the dock.

    nxmac
    Participant

    This issue has recurred, and I wanted to provide more information before trying to troubleshoot further and losing direct access to the details.  Today, on Big Sur 11.6 with the NoMachine 7.6.2 provided above, I had the following order of events (not certain they are all relevant, but if they are, it could be the same as last time and could be actions vs time online):

    1. While connected with NoMachine player, after troubleshooting for the upside down screen issue mentioned in another thread, the NoMachine icon was showing on the Dock even after I closed the only window.
    2. Because the icon isn’t normally there and I don’t want it there, I clicked it to create a new Window and used command+q to close the app.  This got rid of the icon.  The icon in the menu bar stayed, and NoMachine player stayed connected to the desktop.
    3. Blank screen timeout occurred, and NoMachine Player was disconnected.
    4. I woke up the Mac using [removed] to connect to management, then tried to connect with NoMachine player.
    5. NoMachine player prompted for credentials, and after login, stated “<no available desktops on this server>”.
    6. I connected to the Mac using [removed] and noticed the NoMachine icon was gone from the menu bar.
    7. I started NoMachine from Launchpad and the icon reappeared in the menu bar.
      • NoMachine player still appears to be connected on the client with the text from (5) (don’t remember doing this in OP).
      • Server Settings -> Status says “No connected users” (don’t remember checking this in OP).
      • The “Querying the server” icon is greyed out and “Desktop not shared” is shown (same as OP).
      • The buttons for restart server, stop server, and shutdown server are missing (same as OP).
    8. After noting everything above, I closed NoMachine player again and tried to reconnect.  This yielded “The session negotiation failed. Error: Cannot connect to the requested session” (same as OP).
    9. Once again, I am remote and cannot reboot.  The only option on the icon in the menu bar is “Quit NoMachine player”, and it does just that.  I ran the 7.6.2_3 installation package again and it appears to have resolved the issue (NoMachine icon in menu bar now shows desktop shared and says “Quit NoMachine Service” as final option + I can connect with NoMachine player again), meaning re-installation is a good workaround.

    I don’t know what makes the NoMachine icon stick in the Dock, but I suspect command+q on any NoMachine window is what causes the issue.  I also suspect that there should be another (CLI?) way that I can re-launch the service without re-installing or rebooting regardless of whether or not the behavior caused by command+q is a bug.

    in reply to: Big Sur client displaying blank and upside-down #35389
    nxmac
    Participant

    I had this same issue on NoMachine 7.6.2 after upgrading from Big Sur 11.5.2 to Big Sur 11.6.  Restarting the server did not lead to a permission prompt for me or otherwise resolve the issue. However, disabling “Use hardware encoding” and “Use acceleration for display processing” in the performance section of the server settings made the screen come up normal after a server restart. Because I wanted to investigate further what was causing the problem, I re-enabled both settings and restarted the server again.  When I reconnected again, it was still working normally.

    nxmac
    Participant

    Follow-up to my previous post…  The black screen issue may be resolvedly the patched package, but there is still a sleep issue.  I can now connect and login immediately after closing VNC (couldn’t before, had to type before closing VNC), but once the sleep timeout occurs, I still cannot connect at all.  I left NoMachine Player connected in the background for over 10 minutes so the Mac went to sleep.  When I brought the NoMachine player back to the foreground, it did what it always does when this happens, which is try to reconnect.  Because of the blank screen issue, I would normally connect VNC in order to wake the Mac and then NoMachine Player would reconnect (technically, that lead to me not discovering this second issue before now).  Since I was intentionally testing for the blank screen issue, I didn’t connect VNC, and NoMachine Player ultimately timed out on trying to reconnect.  IOW, NoMachine may be waking the screen now, but it isn’t waking the Mac like a VNC client does via the built-in Remote Management feature.  I wanted to verify this anyway, so most of that was planned.  Here are the basic reproduction steps:

    1. Connect NoMachine Player to M1 Mac
    2. Bring a different window into focus on client until Mac is sleeping and NoMachine Player is disconnected
    3. Bring NoMachine Player back to foreground to watch it try to reconnect (and ultimately time out)

    My power options are “Turn display off after 10 min” and “Wake for network access”

    “Prevent computer from sleeping automatically when the display is off” is NOT checked, and the external (only) monitor was powered off during my testing.  I have closed out of NoMachine player and started it back up to reconnect without using VNC after a partial minute, but I have not tested longer increments between 1 and 10 minutes.  As there aren’t really any other energy saver settings, I am assuming the M1 Mac is going to sleep after 10 minutes with no keyboard/mouse activity even though my settings don’t explicitly indicate that.  That theory is supported by the fact that things like cloud synchronization apps and e-mail will stop updating after 10 minutes while this setting remains unchecked, but will keep updated perpetually if I check it.  I suspect the logic is for the Mac to go to sleep when the display is put to sleep while having the display physically turned off doesn’t actually change the timer for the Mac’s sleep (IOW, I suspect this setting is just poorly labeled).

    nxmac
    Participant

    The icon came back and the desktop was shared again as soon as the install completed.  I had not considered attempting to re-install the old version, so I don’t know if the re-install restarted the server or if the new version fixes the issue.  In either case, it appears I can also connect without the VNC workaround now.  I will update this topic again if I see the same behavior in the future.  It may be more than a couple weeks if the behavior is caused by time online, because I may reboot the Mac to reconnect a UPS, which would reset that.

    in reply to: Thunderbird e-mail drag and drop #35218
    nxmac
    Participant

    Thanks for testing, I posted in general thinking I could get random input from some subset of users that do use Thunderbird (because I doubt this issue has to do with M1 Mac specifically).  AFAICT, the version of Thunderbird I mentioned is the latest (says it is up to date in the About screen after appearing to refresh). I tried enabling “Grab the mouse input” and that seemed to help a little bit (though I’m not sure why it would considering that I’m using full screen anyway), but the issue still seems more present than it was with VNC, RDP, or locally.  Specifically, I moved 8-10 e-mails, one at a time, to a few different folders, and about half of them moved on the first try where the other half moved on the second try.  Prior to changing that setting and starting this discussion, I was seeing enough 2nd and 3rd try failures that I was giving up and using the right-click menu to move the e-mails.  That’s a small test in a short period of time, so it’s possible that the better results were a fluke.  Unfortunately, the mouse input capture change makes the VNC to wake NoMachine to connect workaround a bit more difficult, so I’ve turned it back off regardless.

    I also tested with RealVNC’s viewer again after the test above, just to be sure, and I moved at least 20 e-mails, one at a time, with every e-mail moving on the first try. Regarding moves on the first try vs a subsequent try, anytime the e-mail doesn’t move when I try to move it, I see the animation of the e-mail going back to the list as if I tried to drop it between folders.  Oddly, I just noticed that I can move e-mails to a folder without touching the text, so long as the text is highlighted, so my earlier discussion about the pointer not touching the text may not be relevant on Mac (pretty sure the latest version of Thunderbird in July was still only highlighting text when pointing at the text, but not positive if that changed this recently or differs between Mac and Windows).

    To be clear, I’m not convinced it’s actually a problem with NoMachine regardless, but wanted to see others’ experiences.  Also, there are some unique variables in my situation that the software may or may not be able to help with:

    • My mouse is set to a pretty high speed, so the cursor bounces about when I type or even try to hold it still.  I thought this could explain the issue in and of itself until learning that apparently touching the letters of the text is no longer necessary.
    • My Internet uplink at home is slow and flaky (cable is exposed and ISP doesn’t seem to care).  I though this could be countering the previous point when using VNC where NoMachine is much more efficient, but again, that doesn’t seem as relevant now.
    • I have had behavioral issues that may imply the server isn’t seeing the same thing as the client (folder text being highlighted when I’m not pointing at it [may have mentioned this in OP], inability to move the mouse to the bottom of the screen until disconnecting and reconnecting [dragging mouse down while holding an e-mail would do nothing, left and right would go left an right, up would go up, but down would stop at the same point higher than the bottom of the screen], holding modifier keys, but mouse actions act as if I’m not [this applies in and outside of Thunderbird, say I’m holding the “Command” equivalent and click on a link in Safari, it should open in a new tab, but sometimes opens in the same tab instead as if I wasn’t holding the button]).  It may be that poor Internet uplink could explain all of these along with the OP topic.
    • I’m connecting to my router using OpenVPN because the built-in screen sharing isn’t encrypted.  I’m not sure if that could further negatively affect NoMachine communication, but assuming NoMachine uses SSL (I’m under the impression that it does), I could open 4000 on the router to my Mac if that would be better.
    in reply to: Black screen when connecting to idle M1 Mac #35186
    nxmac
    Participant

    I have also been experiencing this issue since I started trying to use NoMachine on my M1 Mac Mini, and I also found the same workaround (use VNC to connect, then NoMachine, then disconnect VNC).  I actually turn my monitor off, like the test that lead to the knowledgeable article.  I appreciate the presence of an official workaround that doesn’t involve third party software, but I am concerned that it may reduce security (prevent the session from locking at all if I forget to manually lock it locally and/or forget to disconnect remotely).  The trouble report appears to indicate that the NoMachine team will be working on a fix; is it the best place to track progress regarding such a fix?

Viewing 8 posts - 1 through 8 (of 8 total)