No audio between two Ubuntu 18.04 machines

Forums / NoMachine for Linux / No audio between two Ubuntu 18.04 machines

Viewing 11 posts - 16 through 26 (of 26 total)
  • Author
    Posts
  • #33527
    AvatarDANZI
    Participant

    Hi,

    Yesterday I sent the logs via email.

    Did you get them?

    Thanks,
    Dan

    #33531
    Avatartsotne
    Participant

    Hi,

    Yes, I got it. The logs show that everything is loaded how it should and there aren’t any errors.

    So it is so weird to not see our sinks/sources in pactl command output. Did you take it during the session?
    Please again, give us the output of list sinks and sources during session from NM player (open terminal during session on server machine from NM player and run same commands there).

    Also, probably you have it already, but if not, install pavucontrol on server machine:
    sudo apt install pavucontrol

    Open it also during session from nxplayer (it will call Pulseaudio Volume control in apps) and upload screen of input and output device tabs, from show control choose all input/output devices.

    #33638
    AvatarDANZI
    Participant

    HI – I replied to your request via email, did you receive them? Any further comments?

    Thanks DAN

    #33642
    AvatarCarin
    Participant

    Hi Dan,

    We did not receive any new email. The last email we received from you is from the 18th of May with the logs. Can you please send it again to forum[at]nomachine[dot]com making sure to reference the title of the topic as the subject? Thanks!

    #33646
    AvatarDANZI
    Participant

    ok I resent them to proper email. thanks dan

    #33648
    Avatartsotne
    Participant

    Hi Dan,
    unfortunately your files still don’t help and it is still weird to me not seeing our sink/source while in logs it is shown that they are loaded without any error. Just to be sure, do you have some custom pulseadudio configuration?

    what is output of this command (again, while you are connected to host machine, using NM player) on host machine:
    ps aux|grep pulse

    also run
    pactl info

    The command pactl info should return a line (among other lines) beginning with “Server String”.

    Please run also the command
    ls -l SERVER_STRING_VALUE_FROM_PACTL_INFO_OUTPUT

    and replace SERVER_STRING_VALUE_FROM_PACTL_INFO_OUTPUT by the actual string which is appended after “Server String”, e.g.

    if it is
    Server String: /run/user/1000/pulse/

    run
    ls -l /run/user/1000/pulse/

    and send us that output, too.

    #33647
    Avatarpaai
    Participant

    Hi all,

    (I would open an new topic, but I can’t find how to do so)

    My problem is rather similar. Two Kubuntu 18.04 machines with the free NoMachine – Version 7.5.2. The server machine has an HDA NVidia sound system. Stand-alone this works. System Settings shows ‘Built in Audio Analog Stereo’ as expected

    But… when I install NoMachine on that server, in System Settings the line ‘Built in Audio Analog Stereo’ is greyed out and three more choices appear: two ‘NoMachine ouput’ lines and one ‘Simultaneous output to NoMachine output’.

    I can stream sound between the computers OK.

    However, I have an amplifier attached to the line-out of the server. So I have the checkbox ‘mute audio on server’ unchecked. This has worked without problems for a few years. But all of a sudden it seems that NoMachine kills the regular ‘Built in Audio Analog Stereo’ because whatever I do no sound comes into the amplifier. If I uninstall NoMachine from the server, the amplifier works again.

    Thank you for reading this.

    paai

     

    #33676
    Avatartsotne
    Participant

    Hi Dan,
    got your email and your config file.

    Why did you disable to load module-switch-on-connect and module-switch-on-port-available?

    They are important modules.

    uncomment them and restart pulseaudio:
    pulseaudio -k

    Then try again and check, if you can see our sink/sources and if you get sound during NoMachine session.

    Hi Paai,
    so you mean that you don’t get audio in amplifier during NoMachine session, yes? or it stops working just after installing NoMachine , without using NoMachine session?

    NoMachine doesn’t “kill/stop” default sinks/source that’s why NoMachine use its own sink/sources.

    Please upload logs (instruction is the same how I advised Dan)

    Just while you will be connected to the host machine using NoMachine, please try to check/uncheck “mute audio on server” option a few times.

    Also provide output of commands of pactl on host machine before you connect using NoMachine and upload screen of pavucontrol output device tab.

    #33682
    Avatarpaai
    Participant

    @Tsotne, I opened a new thread “no hardware sound on server” and copied your answer to me to that thread.  Is it OK that we use that other thread for my problem? https://forums.nomachine.com/topic/no-hardware-sound-on-server

    Paai

     

    #33695
    Avatartsotne
    Participant

    Hi Dan,
    even they are important modules, I tested it and sound loading should still work (I used Ubuntu 18.04 too), so let’s comment them again and restart pulseaudio.

    In the previous reply where I asked you output for
    ps aux|grep pulse

    your output shows that PA is running twice for your user and probably that is the problem.
    let’s check which commands are invoking both instances:
    run again previous ps command and for both PA instance pid (second column is pid) run:
    systemctl status PID_VALUE #replace pid number

    It will get info which process started PA, one should be systemd and let’s check what is second one.

    #33707
    Avatartsotne
    Participant

    Hi Dan,

    One PA instance which was invoked by nxserver is for virtual session, but your logs shows that you are using physical session. Are you using virtual NoMachine session on the host machine?

    According to the logs and output of pactl commands, you should have audio output, or there is something wrong on system or some PA configs are messed up.

Viewing 11 posts - 16 through 26 (of 26 total)

You must be logged in to reply to this topic.