No sound on Mac Safari

Forums / NoMachine for Mac / No sound on Mac Safari

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #21731
    itguy92075
    Participant

    Hello,

    I can’t get sound working on Mac Safari using the NoMachine client version 6.5.6.  I went through the various links given in the forums, and my settings check out ok with what’s suggested.  Things I tried:

    • checked all outputs
    • checked accessibility options — nx allowed everywhere
    • turned off bluetooth
    • reboot
    • check for pulseaudio running — it’s not running
    • tested connection to same server using windows — sound works
    • nxwebplayer works

    Any other suggestions?

    Thanks.

    #21743
    mkub
    Participant

    Hi,

    Does this situation also happen for audio sources different from Mac Safari? Are you able to hear any sounds through session? What is your operating system?

    If Mojave – to resolve the problem, follow links below:

    https://forums.nomachine.com/topic/no-audio-from-macbook-air-to-imac#post-21148

    https://forums.nomachine.com/topic/no-audio-from-an-imac-with-mojave

    https://www.nomachine.com/AR10P01001

    Let us know if this fixes the problem.

    Thanks,
    mkub

    #21749
    itguy92075
    Participant

    Hello,

    I saw that link earlier and confirmed NoMachine processes can access the controls.

    As far as other audio sources, I was able to hear sound during a webinar earlier in the day.

    Thanks.

    #21758
    mkub
    Participant

    Hi,

    Which operating system do you use as a server? Make sure that you have a proper inputs/outputs configuration for both client and server. On a client your input/output should be related to the hardware. If it was working before, probably some settings were changed. Not necessarily NoMachine’s. Did you change any of them related to sound before you noticed the problem with audio streaming?

    How does it with other browsers? Does it behave in the same way?

    Did you try to follow this instruction?

    (…) try to uncheck nxnode app – reboot machine – check nxnode again. If this also did not help, you can add whole NoMachine application to Accessibility.

    Thanks,
    mkub

Viewing 4 posts - 1 through 4 (of 4 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.